Bug 446111 - compiz causes glxgears to run slowly
compiz causes glxgears to run slowly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 15:23 EDT by Philip Ashmore
Modified: 2018-04-11 12:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 17:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.12 KB, text/plain)
2008-05-23 14:16 EDT, Philip Ashmore
no flags Details
Xorg.0.log (23.37 KB, application/octet-stream)
2008-05-23 14:18 EDT, Philip Ashmore
no flags Details

  None (edit)
Description Philip Ashmore 2008-05-12 15:23:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
With compiz window manager
= default window size =
56 frames in 5.0 seconds = 11.121 FPS
68 frames in 5.1 seconds = 13.428 FPS
67 frames in 5.0 seconds = 13.313 FPS
67 frames in 5.1 seconds = 13.215 FPS
61 frames in 5.4 seconds = 11.360 FPS
= full screen (1600x1200) =
4 frames in 5.6 seconds =  0.718 FPS
4 frames in 5.0 seconds =  0.792 FPS
5 frames in 6.2 seconds =  0.808 FPS

With KDE window manager
= default window size =
2934 frames in 5.0 seconds = 586.715 FPS
2937 frames in 5.0 seconds = 587.275 FPS
2879 frames in 5.0 seconds = 575.656 FPS
= full screen (1600x1200) =
190 frames in 5.0 seconds = 37.999 FPS
190 frames in 5.0 seconds = 37.941 FPS


Version-Release number of selected component (if applicable):
compiz-0.6.2-3.fc8.rpm

How reproducible:
Always


Steps to Reproduce:
1. start fusion-icon in KDE
2. select compiz window manager by right clicking the fusion manager and selecting 
    "Select Window Manager/Compiz"
2. in konsole, start glxgears


Actual Results:
glxgears runs slowly

Expected Results:
glxgears shouldn't run more slowly with Compiz window manager than without it.


Additional info:
my smolt page is
http://www.smolts.org/client/show/pub_ddc9f5fc-7111-4440-998e-44945e7d5266
See
http://smolts.org/wiki/pci/10de/0112/1028/00a4
for details of my nvidia configuration.

It also wreaks havoc on resume from hibernate - it ran really slowly (you could see the windows repainting and the caps-lock ket took seconds to update), eventually crashing KDE.
Comment 1 Matěj Cepl 2008-05-23 13:39:15 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Are you using nvidia binary-only drivers?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Philip Ashmore 2008-05-23 14:16:38 EDT
Created attachment 306532 [details]
xorg.conf
Comment 3 Philip Ashmore 2008-05-23 14:18:22 EDT
Created attachment 306533 [details]
Xorg.0.log
Comment 4 Philip Ashmore 2008-05-23 14:25:14 EDT
I use the nvidia binary-only drivers as the 3D / composite performance is
unacceptable otherwise.

If you look at the Xorg.0.log you will also see that I'm using the nvidia
internal AGP driver as the kernel's AGP driver doesn't resume from hibernate on
my system.
Comment 5 Matěj Cepl 2008-05-23 17:37:57 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 6 Philip Ashmore 2008-05-24 11:32:41 EDT
http://www.freedesktop.org/XOrg/XorgMailingLists
    The requested URL /XOrg/XorgMailingLists was not found on this server.

You can check yourself, but I think
    http://lists.freedesktop.org/mailman/listinfo
is the new location.

I created a thread at
http://www.nvnews.net/vbulletin/showthread.php?t=113681&goto=newpost

Note You need to log in before you can comment on or make changes to this bug.