Bug 446113 - nm applet menu is ugly and confused with redundant wireless networks
nm applet menu is ugly and confused with redundant wireless networks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 15:30 EDT by Dan Winship
Modified: 2008-11-03 16:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 16:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2008-05-12 15:30:44 EDT
Once when NM couldn't find my wireless network (because of driver issues which I
know are already reported in other bugs), I tried doing "connect to other
wireless network" and giving it the name of my network which it was failing to
see. I don't remember if it worked. Anyway, that's not the bug.

The bug is that now I have two entries for my home wireless network in the menu
("netnet" and "Auto netnet", appearing in a submenu of the main "netnet" entry),
but:

    1. the submenu indicator pushes the signal strength indicator off to the
       left, destroying the pleasing symmetry of the menu. It would look
       better if every line got shifted left in this case.

    2. the radio button next to the network no longer indicates "this is the
       selected network". Instead, it indicates "you have passed the mouse
       over this menu item an even number of times". That is, it is always
       selected when I first open the menu, whether or not I'm connected to
       the network, and then if I move the mouse over that menu item, the
       radio button changes state each time I do so.

(The reason I don't just remove the duplicate network is because sometimes when
I resume from sleep, I can connect to one of the two copies, but not the other.)
Comment 1 Bug Zapper 2008-05-14 07:03:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Dan Williams 2008-11-02 16:59:22 EST
Is this still an issue with latest F8 or F9 updates (svn4022 or later)?
Comment 3 Dan Winship 2008-11-03 09:37:23 EST
I really don't know. The wireless drivers have improved to the point that I don't need to do the auto-vs-non-auto hack any more. You can consider that FIXED if you want.
Comment 4 Dan Williams 2008-11-03 16:15:36 EST
I do want to :)  Thanks!

Note You need to log in before you can comment on or make changes to this bug.