Bug 446118 - gnucash crashes when trying to add custom report
gnucash crashes when trying to add custom report
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: slib (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 16:10 EDT by Gabriel Somlo
Modified: 2008-08-08 04:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 04:49:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Somlo 2008-05-12 16:10:18 EDT
Description of problem:
upon attempt to add a custom report by clicking the 'add report' button on the
main toolbar, gnucash crashes unceremoniously.

Version-Release number of selected component (if applicable):
gnucash-2.2.4-1.fc8

How reproducible:
Create a custom report, then attempt to save it using the 'Add Report' button
on the main toolbar.

Steps to Reproduce:
1. start gnucash
2. create new set of accounts (I created 'common accounts')
3. create custom report:
    - start by selecting Reports -> Income&Expense -> Cash Flow
    - customize:
        - right click, select 'Report Options'
        - under 'General', change report name to e.g. 'available checking'
        - under 'Accounts', pick 'always show subaccounts' and select e.g.
          'Assets:Checking' and 'Liabilities:Credit Card'
        - click 'OK'
4. attempt to save custom report by clicking 'Add Report' on the main toolbar
  
Actual results:
gnucash crashes.

Expected results:
new report should become available under 'Reports -> Sample and Custom'

Additional info:

This is the crash dump / back trace gnucash prints out when it dies:

Backtrace:
In unknown file:
   ?: 0* [gnc:report-save-to-savefile #]
In /usr/share/gnucash/scm/report.scm:
 420: 1* (let* (# # #) (if # #))
 427: 2  (if (record? save-result) (begin (display saved-form #) (force-output)
...))
 428: 3  (begin (display saved-form #) (force-output) (let # #))
 429: 4* [display ";;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Options for saved report \"Available Checking\", based on template \"Cash Flow\"
(let ()
 (define (options-gen)
  (let ((options (gnc:report-template-new-options/name \"Cash Flow\")))

; Section: General

(let ((option (gnc:lookup-option options
                                 \"General\"
                                 \"Report name\")))
  ((lambda (option) (if option ((gnc:option-setter option) \"Available
Checking\"))) option))


; Section: Accounts

(let ((option (gnc:lookup-option options
                                 \"Accounts\"
                                 \"Always show sub-accounts\")))
  ((lambda (option) (if option ((gnc:option-setter option) #t))) option))

(let ((option (gnc:lookup-option options
                                 \"Accounts\"
                                 \"Account\")))
  ((lambda (option) (if option ((gnc:option-setter option)
'(\"3ca87e08e42e23054afb0db7e9afa012\" \"c2b6cf465cb0a50dea7ca2340a5f314d\"))))
option))

  options))
 (gnc:define-report 
  'version 1
  'name \"Available Checking\"
  'options-generator options-gen
  'menu-path (list gnc:menuname-custom)
  'renderer (gnc:report-template-renderer/name \"Cash Flow\")))

" ...
 430: 5*  (open-file conf-file-name "a")

/usr/share/gnucash/scm/report.scm:430:20: In expression (open-file
conf-file-name "a"):
/usr/share/gnucash/scm/report.scm:430:20: Unbound variable: open-file
Comment 1 Bill Nottingham 2008-05-12 17:05:56 EDT
Can you try the 2.2.5 packages currently in updates-testing?

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-3463
Comment 2 Gabriel Somlo 2008-05-12 19:30:35 EDT
Same problem occurs with 2.2.5-1.fc8 :(
Comment 3 Bill Nottingham 2008-07-17 16:09:56 EDT
I can't reproduce this with the same GnuCash on F9. Will try F8, hopefully soon.
Comment 4 Bill Nottingham 2008-07-18 12:02:48 EDT
OK, with the same versions of Gnucash and guile on F9, this works fine. However,
it fails on Fedora 8.

Fedora 8 ships with slib-3a4-2, while Fedora 9 has slib-3b-1. If you install the
slib from Fedora 9, it works. (You may try that as a workaround.)

Moving bug to slib.
Comment 5 Fedora Update System 2008-07-23 07:10:56 EDT
slib-3b1-1.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-08-07 19:54:57 EDT
slib-3b1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.