Bug 446136 - RHEL4.8: enable deep C states on Nehalem for idle efficiency
RHEL4.8: enable deep C states on Nehalem for idle efficiency
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
high Severity high
: beta
: ---
Assigned To: John Villalovos
Martin Jenner
: FutureFeature, HardwareEnablement, OtherQA
Depends On:
Blocks: 435612 435614 450719 450791 450796 452249 458123
  Show dependency treegraph
 
Reported: 2008-05-12 18:56 EDT by Geoff Gustafson
Modified: 2015-05-08 10:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 16:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2008-05-12 18:56:27 EDT
1. Feature Name: enable deep C states for Nehalem

Because RH is getting some late pressure from OEMs and customers for
TylersburgEP/Nehalem support in 4.7, I'm concerned that this might be required.
We had intended only to submit it for 5.3, but I now plan to look at it ASAP in
the 4.7 context.

This patch that went upstream in June 2007 gives a a 16x improvement in
efficiency at idle on Nehalem chips.

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=18eab8550397f1f3d4b8b2c5257c88dae25d58ed

2. Description:
Architectures (mark all that apply)
x 32-bit x86
  64-bit Itanium2
x 64-bit Intel EM64T

Dependencies:
External links:
Priority (H,M,L): H
Target Releases:
Target Release Date:
Drivers or hardware dependency:
Target Kernel:

3. Business Justification:
a. Why is this feature needed?
Big power efficiency improvement
b. What hardware does this enable?
Nehalem CPUs
c. Forecast, volume or high end platform?
Volume
d. Any configuration info?
e. When needed?
f. Are there other dependencies (drivers).

4. Status:
a. Is code accepted upstream? If so, what version or patch?
See above.

5. Hardware to Red Hat? Red Hat can't integrate/test features without hardware.
Yes, two alpha Tylersburg EP and one Tylersburg HEDT are already at RH, more coming.

6. Partner management contact, email, phone, chat
keve.a.gabbert@intel.com

7. Partner technical contact, email, phone, chat
jvillalo@redhat.com, grgustaf@redhat.com
Comment 1 Ronald Pacheco 2008-05-13 23:11:01 EDT
The Nehalem processor is integral to the Tylersburg-EP platform that all of the
OEMs will be planning.  Moreover, the deep c-states improves the overall power
efficiency of idle CPUs, which many customers are very interested in.
Comment 4 Daniel Riek 2008-06-10 10:44:09 EDT
This request is not going to be addressed in RHEL 4.7. Moving to 4.8.
Comment 7 Ronald Pacheco 2008-07-29 09:01:03 EDT
John, is 443516 dup of this BZ?
Comment 8 Ronald Pacheco 2008-07-29 09:01:38 EDT
John, never mind!  443516 is the 5.3 equivalent.  
Comment 10 John Villalovos 2008-08-26 16:15:50 EDT
It has been decided that this bug will be to intrusive to fix for RHEL 4.x.  We will only support deep c-states in RHEL 5.3 and beyond.

Note You need to log in before you can comment on or make changes to this bug.