Bug 446137 - [RFE] luci: set IP-Address or Host for listen on
[RFE] luci: set IP-Address or Host for listen on
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Cluster_Administration (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation, FutureFeature
Depends On:
Blocks: 617634
  Show dependency treegraph
 
Reported: 2008-05-12 18:59 EDT by Jan Kellermann
Modified: 2011-07-25 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 617634 (view as bug list)
Environment:
Last Closed: 2011-07-25 09:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kellermann 2008-05-12 18:59:26 EDT
Request for Enhancement: If you want to use luci in a server-infrastructure 
with more than one network you want access luci only from internal network.

The easiest way is to configure the stunnel-component to listen only on one ip. 
This is possible with 
LUCI_HTTPS_PORT=10.10.10.10:8084
in /etc/sysconfig/luci

It would be better to adopt a own variable and use it in the init-script and 
correct $LUCI_URL for correct output.
Comment 4 Paul Kennedy 2010-07-23 11:30:49 EDT
Changing component to documentation component "Cluster_Administration" since this is a procedural issue.
Comment 5 RHEL Product and Program Management 2010-08-09 14:18:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Steven J. Levine 2011-01-27 12:37:11 EST
Ryan:

I'm looking at a bunch of the Cluster documentation bugs, and I have a couple of questions about this one:

1) This is technically a RHEL 5 bug, but does it apply to RHEL 6 as well?

2) It looks to me as if I can just add this procedure to this section:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Cluster_Administration/s2-iptables-conga-CA.html

Does that makes sense, simply to add this information to that existing subsection?

3) I'm not sure what this is saying -- there seems to be a typo of sorts:

It would be better to adopt a own variable and use it in the init-script and 
correct $LUCI_URL for correct output.

"a own variable"?  What does that refer to?

Thanks,

-Steven Levine
Comment 8 Steven J. Levine 2011-02-07 14:56:21 EST
Marking as needinfo from Ryan McCabe as per Comment 6.
Comment 9 Ryan McCabe 2011-06-22 13:28:10 EDT
I imagine "own variable" was a typo for environment variable, which is a feature that has not been implemented. The way to configure this is to change the LUCI_HTTPS_PORT parameter in the /etc/sysconfig/luci file as described in comment #1

Note You need to log in before you can comment on or make changes to this bug.