Bug 446147 - CIFS -- fix setting of DELETE_ON_CLOSE in CreateAndX
CIFS -- fix setting of DELETE_ON_CLOSE in CreateAndX
Status: CLOSED DUPLICATE of bug 239678
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jeff Layton
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 20:54 EDT by Jeff Layton
Modified: 2014-06-18 03:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 11:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2008-05-12 20:54:55 EDT
Windows clients do not set the DELETE_ON_CLOSE bit when opening a file with
CreateAndX. They instead do a SET_FILE_INFO call and set the delete on close bit
there.

Some CIFS servers do not handle delete-on-close bit being set in the create
call. It needs to be set in a follow-on SET_FILE_INFO call. Samba apparently
ignores the bit unless you are actually creating the file. Netapp's server also
seems to have problems with the current scheme.
Comment 1 Jeff Layton 2008-05-23 11:09:40 EDT

*** This bug has been marked as a duplicate of 239678 ***

Note You need to log in before you can comment on or make changes to this bug.