This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446166 - mesa depends on xorg-x11-proto-devel >= 7.3.12
mesa depends on xorg-x11-proto-devel >= 7.3.12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-05-13 02:57 EDT by Zhan, Yi
Modified: 2008-05-13 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 14:40:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhan, Yi 2008-05-13 02:57:32 EDT
Description of problem:

mesa.spec says "BuildRequires: xorg-x11-proto-devel >= 7.1-10", but when build
mesa with xorg-x11-proto-devel-7.3.11 or lower versions below error would be
seen and build would fail:
 
checking for DRI2PROTO... configure: error: Package requirements (dri2proto >=
1.1) were not met:

Requested 'dri2proto >= 1.1' but version of DRI2Proto is 1.0.0

The full log can be found at
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=69914&name=build.log. 

I saw this on ia64 but I image this is not a architecture related issue.

Version-Release number of selected component (if applicable):
from mesa-7.1-0.25 to mesa-7.1-0.30

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Jackson 2008-05-13 14:40:33 EDT
Fixed, mesa now requires dri2proto >= 1.1 explicitly.

I'm curious how you managed this though, 7.3-12 is the newest version available
in dist-f9.
Comment 2 Zhan, Yi 2008-05-13 22:33:07 EDT
(In reply to comment #1)
> Fixed, mesa now requires dri2proto >= 1.1 explicitly.
> 
> I'm curious how you managed this though, 7.3-12 is the newest version available
> in dist-f9.

Thanks for the quick fix. I'm in the fedora ia64's maintainer team. I had chance
to see this since mesa failed to build on ia64's koji for a while due to this. 

Note You need to log in before you can comment on or make changes to this bug.