Bug 446233 - Galeon does not support basic authentication
Galeon does not support basic authentication
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-13 12:49 EDT by Jan "Yenya" Kasprzak
Modified: 2008-10-07 05:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-07 05:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2008-05-13 12:49:52 EDT
Description of problem:
Galeon in F9 has probably been compiled without HTTP basic authentication
support. It displays the 401 page without asking user for login name and password.

Version-Release number of selected component (if applicable):
galeon-2.0.5-1.fc9 (tried i386 and x86_64)

How reproducible:
100 %

Steps to Reproduce:
1. Run "galeon https://is.muni.cz/auth/" (or any other site which uses the basic

Actual results:
The 401 error page is displayed

Expected results:
The dialog window with the realm name, and login+password input boxes should
be displayed.

Additional info:
Apparently firefox-3.0-0.60.beta5.fc9 works as expected.
Comment 1 Peter Hanecak 2008-05-30 10:34:34 EDT
I've got galeon-2.0.5-1.fc9.x86_64 too and I see same behaviour.

Quite nasty after using galeon for so many years. :/
Comment 2 Stu Tomlinson 2008-05-30 11:13:45 EDT
It seems this is known, from /usr/share/doc/galeon-2.0.5/NEWS:

2.0.5 "1 step forward, 2 steps back"

- Works with Firefox 1.5.x and xulrunner 1.8.x
- Compiles with xulrunner 1.9, but a lot of functionality is disabled due
  to being no longer exposed by xulrunner (or not working)
  - MyPortal
  - User stylesheets
  - Remembering passwords
  - http authentication

Would have been nice to see this mentioned in the release notes.
Comment 3 Jan "Yenya" Kasprzak 2008-05-30 11:28:31 EDT
As a quick band-aid fix, downgrade to the Fedora 8 version of Galeon worked for me.

Remove xulrunner, yelp, firefox, epiphany, galeon (and maybe other dependencies),
and install galeon and firefox from Fedora 8 updates.
Comment 4 Jonathan Wakely 2008-07-06 08:26:25 EDT
Well this sucks.
Comment 5 Jan ONDREJ 2008-07-06 15:32:06 EDT
Galeon 2.0.6 has been released. I don't know, if this problem has been fixed,
but may be some yes.
Comment 6 Denis Leroy 2008-07-08 04:04:23 EDT
I have a 2.0.6 src rpm ready, after much configure.in hackage as usual. I'll put
this up here for testing before I submit it, simply because I can't really see
any significant improvement. Let me know what you guys think.

Comment 7 Jan ONDREJ 2008-07-08 10:31:25 EDT
Still same problems. :-(

Just a tip for those who want to use http auth with this galeon. You can use
this URL:
It works, but your password is displayed in URL. If your password is not very
secret, then it's a way. :-)
Comment 8 Jan ONDREJ 2008-07-10 09:16:12 EDT
Just for your information:
  flash and other plugins are not loaded with your package of galeon-2.0.6,
older versions are without problems. It is still trying to redirect me to flash
installation site.
Comment 9 Jan ONDREJ 2008-09-27 03:37:10 EDT
Upstream released new version:

2.0.7 "Surprise!"

- Works with Firefox 2/3 and Xulrunner 1.8/1.9
  - Restored support for http authentication by Mike Hommey <mh@glandium.org>
  - Restored support for remembering passwords.
  - Partially restored support for user stylesheets.
    - Effect is global rather than per page but UI doesn't reflect this.

May be printing will still not work.
Comment 11 Jan ONDREJ 2008-09-27 10:23:39 EDT
Thank you!

Authentication works for me.

There are still problems with:
- printing
- it's hard to add exception for unknown https sites
Comment 12 Fedora Update System 2008-09-27 13:23:48 EDT
galeon-2.0.7-1.fc9 has been submitted as an update for Fedora 9.
Comment 13 Fedora Update System 2008-10-01 02:38:59 EDT
galeon-2.0.7-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update galeon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8478
Comment 14 Fedora Update System 2008-10-07 05:49:35 EDT
galeon-2.0.7-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.