Bug 446241 - Vertical maximization does not sometimes work
Vertical maximization does not sometimes work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 13:30 EDT by Jan "Yenya" Kasprzak
Modified: 2014-06-18 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 14:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2008-05-13 13:30:18 EDT
Description of problem:
When I bind a "maximize_vertically" window keybinding to some key (say,
<Control><Shift>F10), and use this key on gnome-terminal or other apps (tried
also gconf-editor), it is maximized even behind the GNOME panel (which I have
near the bottom edge of the screen). When I hide and unhide this panel, the
terminal becomes maximized as expected, i.e.  aligned with the upper edge of the
manel. Subsequent vertical maximizations and unmaximizations then work as expected.

Version-Release number of selected component (if applicable):
metacity-2.22.0-3.fc9.x86_64

How reproducible:
Sometimes - more often on newly opened windows. I am not able to determine
exactly when this happens and when it doesn't.

Steps to Reproduce:
1. Run a GNOME session with metacity as the window manager, have a panel at the
bottom edge of the screen.
2. Open gconf-editor and set
/apps/metacity/window_keybindings/maximize_vertically to "<Control><Shift>F10".
3. Start gnome-terminal.
4. Press <Control><Shift>F10 to maximize it vertically.
  
Actual results:
The terminal is maximized even behind the GNOME panel, having last few rows
obscured.

Expected results:
It should be maximized only upto the upper edge of the panel.

Additional info:
I have also tried to add a "maximize vertically" button to the title bar (adding
"maximize_vertically" to the /apps/metacity/general/button_layout gconf key, but
it does not work (probably the button should be named differently).

Note You need to log in before you can comment on or make changes to this bug.