Bug 446269 - Unable to remove packages for a client via the webui if the channel is not subscribed
Unable to remove packages for a client via the webui if the channel is not su...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
511
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://rlx-3-14.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-05-13 16:40 EDT by wes hayutin
Modified: 2009-09-10 16:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-05-13 16:40:49 EDT
Description of problem:

Example..
you have rhncfg from the tools channel installed on a system.
However the tools channel is not subscribed.

In the webui if you go to list/remove packages in the sdc..
and remove the package.

then run rhn_check on the client..
no jobs are found, and nothing is picked up..

if you subscribe the channel.. then you can remove the package.

I suspect due to dependency resolution this may be a problem... however it looks
like we allow it in the webui.. so we need to fix something.
Comment 2 Clifford Perry 2008-05-14 10:24:35 EDT
<parthonista> cliff: I just chatted with weshay on
https://bugzilla.redhat.com/show_bug.cgi?id=446269
<weshay> ya .. that can move to 5.2 
<parthonista> cliff: sounds like the behviour was identical in 5.02 to 5.10
<parthonista> cliff: so its not a 'regression' per se
Comment 4 Justin Sherrill 2009-03-25 15:29:11 EDT
Made removal work now if the package is not in any of the systems subscribed channels.

We now throw this warning:

One or more of the packages you have selected for removal below are not contained in a software channel that this system is subscribed to. If you choose to continue with the removal you will not be able to rollback this system to this snapshot or any prior snapshot.

If the system has a provisioning entitlement and one of the packages selected for removal isn't in any of the channels the system is subscribed to.
Comment 5 Justin Sherrill 2009-03-25 15:32:32 EDT
Tested with RHEL 4 and RHEL 5 clients.

Basically had to split up the 'update' and 'remove' actions into 2 different queries in the backend.  One that restricted based on server channels and one that didn't.


commit	80f273a1c6511637611e586711b58b5f94462e96
tree	e46d8630ee265022a711706ee9e157768496eb2c	tree | snapshot
parent	1e2fad3293b836a96ce3c1c71ddb626cc14ca6b2	commit | diff
Comment 6 wes hayutin 2009-04-23 10:55:00 EDT
verified on 4/20
Comment 7 Milan Zazrivec 2009-08-13 07:35:19 EDT
Verified in stage -> RELEASE_PENDING
Comment 8 Brandon Perkins 2009-09-10 16:25:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.