Bug 446276 - GRUB does not install when ext4 is root filesystem
GRUB does not install when ext4 is root filesystem
Status: CLOSED DUPLICATE of bug 486284
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 16:53 EDT by Ronny Fischer
Modified: 2009-03-01 04:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-01 04:50:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2008-05-13 16:53:32 EDT
Description of problem:
A fresh installation of Fedora 9 won't complete because GRUB isn't installed

Version-Release number of selected component (if applicable):
Fedora 9, x86_64

How reproducible:

just tried one time with ext4

Steps to Reproduce:
1. install F9 including GRUB on x86_64 on a ext4 filesystem 
2.
3.
  
Actual results:

installation of GRUB stops the overall installation

Expected results:

installation should continue and finish 

Additional info:

Hardware is pretty new but known to work. Intel Core 2 Duo E8xxx series, Intel 
P35 chipset, AHCI mode for HDD

Fedora 8 installed on the same system (on ext3) without problems, the same as 
Fedora 9 on ext3. The system works as a dual boot system with Windows Vista. 
The boot loader is installed into the MBR.
Comment 1 Jan "Yenya" Kasprzak 2008-12-17 09:09:10 EST
I have found a patch for GRUB 0.97 to read ext4 extents:

http://www.mail-archive.com/bug-grub@gnu.org/msg11458.html

However, even when I rebuild the GRUB src.rpm with this patch, it installs on the ext4 volume, but then booting fails with "Error 15". There is also an OpenSUSE RPM which apparently supports ext4 through the similar patch. I tried just to take the patch (and edit it so that it fits the Fedora version of GRUB), but got the same error message during boot.

Since the upstream has declared they are not willing to add ext4 support to GRUB 0.97, the solution would be either to fix and maintain it as a Fedora patch, or migrate Fedora to GRUB 1.9x.

Please change Version: to Fedora 10, as this applies also to F10 version of GRUB.
Comment 2 Peter Gordon 2009-02-11 10:52:23 EST
Have there been any updates on the GRUB/Ext4 front? Thanks. :)
Comment 3 lexual 2009-03-01 04:50:42 EST

*** This bug has been marked as a duplicate of bug 486284 ***

Note You need to log in before you can comment on or make changes to this bug.