Bug 446283 - Preset radio station does not work in rhythmbox
Preset radio station does not work in rhythmbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 17:46 EDT by petrosyan
Modified: 2009-03-24 11:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 11:06:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2008-05-13 17:46:59 EDT
Description of problem:
Due to a known bug in gstreamer preset radio stations
WKNC 88.1 FM (NC State) (Broadband)
and
WKNC 88.1 FM (NC State) (Modem)
stop working when a new song is about to start, and rhythmbox player stops
working until restarted.

Even though this is a gstreamer bug, I don't see a reason for shipping preset
radio stations in rhythmbox which are guaranteed to fail.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-9.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. open rhythmbox
2. listen to WKNC 88.1 FM (NC State) (Broadband) or WKNC 88.1 FM (NC State)
(Modem) radio station.
3. wait until the current song is over and a new is about to start.
Comment 1 Bastien Nocera 2008-05-13 19:30:50 EDT
(In reply to comment #0)
> Description of problem:
> Due to a known bug in gstreamer preset radio stations

What known bug?
Comment 2 petrosyan 2008-05-14 00:50:28 EDT
It is this bug: http://bugzilla.gnome.org/show_bug.cgi?id=320984

It seems to have been fixed in playbin2, but rhythmbox apparently is still
susceptible to this problem. 
Comment 3 petrosyan 2008-05-17 12:16:25 EDT
It is kind of ironic that the only format for listening to online radio that is
supposed to work in Fedora still does not work. Even for the preset radio stations.
Comment 4 petrosyan 2008-07-27 12:58:48 EDT
this bug is still present in rhythmbox-0.11.6-2.fc9.x86_64
Comment 5 Bastien Nocera 2009-03-24 11:06:23 EDT
Fixed in rhythmbox-0.12.0-2 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.