Bug 446295 - Submitted fix: Improper formatting in between-mission text boxes
Submitted fix: Improper formatting in between-mission text boxes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blobAndConquer (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 19:08 EDT by Chris Schembari
Modified: 2008-05-17 18:25 EDT (History)
0 users

See Also:
Fixed In Version: 0.93-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected text files. (3.08 KB, application/x-tgz)
2008-05-13 19:08 EDT, Chris Schembari
no flags Details
Screenshot of one of blobAndConquer's between-mission interludes. (57.46 KB, image/jpeg)
2008-05-13 19:23 EDT, Chris Schembari
no flags Details
Corrected text files, as well as a copy of the originals for comparison. (14.63 KB, patch)
2008-05-15 19:59 EDT, Chris Schembari
no flags Details | Diff
Composite of six annotated screenshots from game (v. 0.93-1.fc8). (376.27 KB, image/jpeg)
2008-05-15 20:01 EDT, Chris Schembari
no flags Details
Newly re-corrected text files for bAC -0.93-1.fc8. (18.02 KB, patch)
2008-05-17 01:11 EDT, Chris Schembari
no flags Details | Diff
Newly revised text files for bAC 0.91 (3.71 KB, patch)
2008-05-17 01:30 EDT, Chris Schembari
no flags Details | Diff
Errors noticed in in-game info boxes and game documentation (0.93) (2.18 KB, text/plain)
2008-05-17 03:37 EDT, Chris Schembari
no flags Details
Composite of two game screenshots (0.93). (140.90 KB, image/jpeg)
2008-05-17 03:47 EDT, Chris Schembari
no flags Details

  None (edit)
Description Chris Schembari 2008-05-13 19:08:28 EDT
Yay, something I could actually fix, and not just complain about!

Description of problem:
  In between certain missions of the game, the user is shown one or more 
colorful 2D pictures with a text box at the bottom to give him some useful 
data about the level he just completed, or the one coming up, or both.  Except 
that there is usually only a brief and cryptic phrase in the box, not anything 
useful.
  I suspected that the game might not be displaying all of the text intended, 
so I looked for and found the text files from which that data is drawn, in 
this directory:  /usr/share/blobAndConquer/data/cutscenes/text/en/
  I found that there were several line-breaks inserted into the text for each 
picture scene, and after I deleted these, the full text displayed correctly.
  I've attached my fix, which is all of the "cutscenes" text files with the 
extraneous line-breaks removed.  I also corrected a few typo's and at least 
tried to add the double-space-after-completed-sentence convention.
  Note that this is for English only, and any other languages that this game 
supports will have to be additionally checked and corrected.

Version-Release number of selected component (if applicable):
  BlobAndConquer 0.91
Comment 1 Chris Schembari 2008-05-13 19:08:28 EDT
Created attachment 305303 [details]
Corrected text files.
Comment 2 Chris Schembari 2008-05-13 19:23:26 EDT
Created attachment 305304 [details]
Screenshot of one of blobAndConquer's between-mission interludes.

  In looking this over, I thought I should provide an example to clarify the
problem.  With the extra line-break characters in the text, the computer would
see that short paragraph as several paragraphs and only display the text from
the last line, after the last mid-sentence line-break.
  Example:  Just before starting the "Waste Disposal" mission, a scene is
depicted with text from the file wasteStart at the bottom.  The attached
screenshot is from Scene2 of that interlude.  Before my fix, all that would
appear in the text box at bottom would be some mysterious phrase like "properly
equipped to handle their predicament.", and nothing else.  This screenshot
shows that interlude with the fixed files, of course.
Comment 3 Hans de Goede 2008-05-14 14:25:41 EDT
I think upstream already has this fixed in a different (better) way in 0.93, can
you give the version you can download here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=49063

A try please?

Note that if you have any ~/.parallelrealities/blobAndConquer/0000? directories,
you need to remove them as those are old incompatible savegames.

~/.parallelrealities/blobAndConquer/0000? files may work fine (but then again
they may not).
Comment 4 Chris Schembari 2008-05-15 14:54:11 EDT
  I tried out 0.93-1 from the link you gave me.  Unfortunately, this version of 
the game has the same typing errors and only shows the same partial messages in 
between game levels.  Like before, I soon will upload fixed text files, this 
time taken from the 0.93-1 version of those files.
  I first deleted (as opposed to sending to the trash) my entire 
~/.parallelrealities/blobAndConquer/ directory, then used Add/Remove Software 
to eliminate the whole blobAndConquer 0.91 package, then used Software 
Installer on blobAndConquer-0.93-1.fc8.x86_64.rpm and 
blobAndConquer-debuginfo-0.93-1.fc8.x86_64.rpm, both at the same time.
Comment 5 Chris Schembari 2008-05-15 19:59:07 EDT
Created attachment 305564 [details]
Corrected text files, as well as a copy of the originals for comparison.

Here are the corrected text files, as well as a copy of the originals for
comparison, specifically for BlobAndConquer 0.93-1.fc8.
I corrected numerous typographical errors, mostly deleting the end-of-line
characters, though there were a few misspellings, too.
Comment 6 Chris Schembari 2008-05-15 20:01:51 EDT
Created attachment 305565 [details]
Composite of six annotated screenshots from game (v. 0.93-1.fc8).

Here are six screenshots once again illustrating the problem.
Comment 7 Hans de Goede 2008-05-16 02:37:40 EDT
Thanks!

I've just send a mail upstream (which is pretty responsive) about this, as I'm
not sure simply removing the new lines is the best solution.

I'm sure upstream will be happy with the type fixes :)
Comment 8 Chris Schembari 2008-05-17 01:11:39 EDT
Created attachment 305785 [details]
Newly re-corrected text files for bAC -0.93-1.fc8.

I've been testing the files I uploaded earlier (attachment #305564 [details]) for
BlobNConq 0.93 and found that I'd introduced new errors in the text. 
Specifically, in trying to get double-spaces after each sentence end, I tried
using a regular space character followed by a non-breaking space (in OOo
Writer, Ctrl+Spacebar), which within these game interludes only looked like a
capital A with a diacritic mark on top.  It also led KDE to identify those
files as "unknown" binary files!  This revised version eliminates those
characters and is all-around better.
Btw, the "blokes" upstream will no doubt be relieved to know that in correcting
the spelling, I was careful to leave alone such British-isms as 'utilise'.  I
may have rearranged some words here or there so as to trim a sentence where I
felt it had a trifle too many syllables.
Comment 9 Chris Schembari 2008-05-17 01:30:59 EDT
Created attachment 305786 [details]
Newly revised text files for bAC 0.91

In light of my last submission to this bug report (for 0.93), I re-reviewed the
text files for BlobNConq 0.91 to make sure there were no bad space characters
within.  This should be my very last upload on this matter!
Comment 10 Hans de Goede 2008-05-17 02:27:47 EDT
I've discussed this with upstream and we both agree that the only showing the
last line is a code bug, your removal of all newlines is merely a workaround.

Upstream will fix this properly and look at integrating your spelling fixes for
the next release.

In the mean time I've applied your latest set of modified files to the Fedora
package to have this fixed until upstream comes with a new version.
Comment 11 Fedora Update System 2008-05-17 02:49:11 EDT
blobAndConquer-0.93-2.fc8 has been submitted as an update for Fedora 8
Comment 12 Chris Schembari 2008-05-17 03:37:18 EDT
Created attachment 305789 [details]
Errors noticed in in-game info boxes and game documentation (0.93)

>>  This should be my very last upload on this matter!
I have another submission to make here.  It's not related to the
between-missions text, so the above statement is still true!
This concerns additional typographical and sundry errors that I noted either in
gameplay or in the game's documentation.  Details in attachment.
Comment 13 Chris Schembari 2008-05-17 03:47:17 EDT
Created attachment 305790 [details]
Composite of two game screenshots (0.93).

... and here is one of my "signature" screenshot-composite pictures
illustrating the first two typos mentioned in attachment #305789 [details].
BTW, is it permissible to squeeze these in here, since they _are_
typing-related, but are not related to the between-missions bug?  I didn't want
to create an entirely separate bug report, and I think that I've given enough
data to make them very quick and easy fixes!
Comment 14 Hans de Goede 2008-05-17 04:48:19 EDT
I'm sorry, but I've already build 3 packages (one for F-8 one for F-9 and one
for devel). With your previous set of fixes in, and I'm not going to keep on
going building packages.

The previous problem with whole parts of text disappearing warranted an updated
thse typo's although annoying IMHO do not warrant an update.

That does not mean they should not be fixed though. I'm sure upstream is more
then happy to have this fixes and incorporate them in his next release (which
once available will become a Fedora update).

You can find upstreams mail address at the end of:
/usr/share/doc/blobAndConquer-0.93/README
Comment 15 Fedora Update System 2008-05-17 18:25:22 EDT
blobAndConquer-0.93-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.