Bug 446298 - amd cool n quiet does not work well with recent kernel
amd cool n quiet does not work well with recent kernel
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 19:16 EDT by Martin Jürgens
Modified: 2008-05-18 10:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-18 10:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-05-13 19:16:35 EDT
Description of problem:
I have AMD cool n quiet activated in my kernel. I noticed starting from a later
kernel release in rawhide (2.6.25 or later) that this causes some problems. For
example, when I am surfing using Firefox, the cpu is set to 1 GHz, but sometimes
Firefox hangs, and instead of getting 1,8 GHz out of my cpu, it just stays at 1
GHz which is why Firefox hangs.

i had a similar problem with Fedora 7 which was fixed by some kernel update.
Comment 1 Dave Jones 2008-05-13 19:25:14 EDT
it'd be interesting to know what firefox is doing when it hangs.
If it's blocking on network or disk, then that would explain it, as raising the
CPU speed wouldn't change the situation.

Can you strace it, and observe what it's doing when it hangs ?
Comment 2 Martin Jürgens 2008-05-13 19:34:35 EDT
I'll do it tomorrow. I have the feeling that it appears often when scrolling and
only when having booted up. As soon as I surf for 15 minutes, I never encounter
the lags to the next restart.

I'll also check some older kernels, I think that it did not happen with
2.6.25-1. Maybe some realtime thingies?
Comment 3 Martin Jürgens 2008-05-18 10:49:53 EDT
Well, it is more likely due to a bug in Firefox and has nothing to do with the previous bug. I'll wait for RC1 
flow in to Fedora and then reopen it if needed (there were reports that it was a bug in FF)

Note You need to log in before you can comment on or make changes to this bug.