Bug 446308 - Fedora 9 doesn't boot xen kernel, using luks encrypted root volume
Fedora 9 doesn't boot xen kernel, using luks encrypted root volume
Status: CLOSED DUPLICATE of bug 437930
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
9
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 20:58 EDT by Franklin Ybanez
Modified: 2008-05-13 21:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 21:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (465.83 KB, application/x-bzip)
2008-05-13 21:01 EDT, Franklin Ybanez
no flags Details

  None (edit)
Description Franklin Ybanez 2008-05-13 20:58:49 EDT
Description of problem:
Fedora 9 doesn't boot xen kernel, using luks encrypted root volume.

Version-Release number of selected component (if applicable):


How reproducible:
Install kernel-xen, modify grub to boot xen kernel.

Steps to Reproduce:
1.
yum -y install kernel-xen
2.
Edit /etc/grub.conf for xen kernel to attempt to use same "ro root=UUID=..."
appended line in grub, as non-xen kernel; and attempt to boot; expecting luks
password prompt during boot process.
  
Actual results:

While trying on IBM Thinkpad T60 (RedHat Internal Employee sanctioned Laptop):
it's as if someone hits the reset button on the machine at the point the user
expects a luks password prompt. (the machine does a hard powercycle; instead of
booting, at the "VGA Console" type message point).

I've included a sysreport for engineering's convenience (from non-xen kernel).


Expected results:

LUKS Password prompt during pivot root process, as in non-xen kernel.

Additional info:

See attached sysreport.
Comment 1 Franklin Ybanez 2008-05-13 21:01:28 EDT
Created attachment 305312 [details]
sysreport
Comment 2 Daniel Berrange 2008-05-13 21:25:23 EDT
Unfortunately, kernel-xen in F-9 does not support Dom0, so this is expected.

If you require a Xen Dom0, you'll need to use F-8 until F-10.

See here for more details:

  http://fedoraproject.org/wiki/Features/XenPvops


*** This bug has been marked as a duplicate of 437930 ***

Note You need to log in before you can comment on or make changes to this bug.