Bug 446335 - OpenVPN connection fails: script failed: shell command exited with error status: 1
OpenVPN connection fails: script failed: shell command exited with error stat...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Höger
Fedora Extras Quality Assurance
:
Depends On: 452506
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 01:53 EDT by Robert Hancock
Modified: 2013-01-22 15:40 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 16:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patched rpm (135.74 KB, application/x-rpm)
2008-06-04 06:29 EDT, Christoph Höger
no flags Details

  None (edit)
Description Robert Hancock 2008-05-14 01:53:18 EDT
Description of problem:
When attempting to connect to a user-defined OpenVPN server, I get "The VPN
connection 'xxx' failed because the VPN service stopped unexpectedly". This
happens immediately.

Version-Release number of selected component (if applicable):
NetworkManager-openvpn-0.7.0-10.svn3632.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1. Define an OpenVPN connection with pre-shared key, and in Advanced tab, a set
of networks to use the VPN for and a custom gateway port.
2.
3.
  
Actual results:
I get this in /var/log/messages:


May 13 23:50:19 Dothan nm-openvpn[7175]: OpenVPN 2.1_rc7 i386-redhat-linux-gnu
[SSL] [LZO2] [EPOLL] built on Feb 21 2008
May 13 23:50:19 Dothan kernel: tun0: Disabled Privacy Extensions
May 13 23:50:19 Dothan nm-openvpn[7175]: TUN/TAP device tun0 opened
May 13 23:50:19 Dothan nm-openvpn[7175]: /sbin/ip link set dev tun0 up mtu 1500
May 13 23:50:19 Dothan NetworkManager: <info>  VPN plugin state changed: 3
May 13 23:50:19 Dothan nm-openvpn[7175]: /sbin/ip addr add dev tun0 local
192.168.233.78 peer 192.168.233.77
May 13 23:50:19 Dothan nm-openvpn[7175]:
/usr/bin/nm-openvpn-service-openvpn-helper tun0 1500 1544 192.168.233.78
192.168.233.77 init
May 13 23:50:19 Dothan NetworkManager: <info>  VPN connection 'SED' (Connect)
reply received.
May 13 23:50:19 Dothan nm-openvpn[7175]: script failed: shell command exited
with error status: 1
May 13 23:50:19 Dothan nm-openvpn[7175]: Exiting
May 13 23:50:19 Dothan NetworkManager: <info>  VPN plugin state changed: 6
May 13 23:50:19 Dothan NetworkManager: <WARN>  connection_vpn_state_changed():
Could not process the request because no VPN connection was active.

Expected results:
VPN connection actually works

Additional info:

The user error feedback for problems like this needs to be improved. The error
message gives no hint whatsoever of what went wrong or where to look for more
info. Even the /var/log/messages output is hardly useful.
Comment 1 Christoph Höger 2008-05-29 14:54:28 EDT
Ok I'm on it.
I can reproduce it, and asked upstream (Dan Williams ;)) for support. 

Sorry for the late answer.
Comment 2 Christoph Höger 2008-06-04 06:29:05 EDT
Hi,

again sorry for the unresponsiveness. 

Could you please try that slightly patched rpm?
Comment 3 Christoph Höger 2008-06-04 06:29:46 EDT
Created attachment 308333 [details]
patched rpm
Comment 4 Robert Hancock 2008-06-09 17:04:55 EDT
Sorry for the delay in testing. Unfortunately it looks like it is still failing
with the same error:

Jun  9 15:03:12 Dothan nm-openvpn[2939]: script failed: shell command exited
with error status: 1

Is there a way to get more debug information than this?
Comment 5 Christoph Höger 2008-06-13 12:05:30 EDT
I've just built a package that should fix this issue.

Could you please grep and test from

http://koji.fedoraproject.org/koji/buildinfo?buildID=52551

thank you.
Comment 6 Fedora Update System 2008-06-16 04:36:29 EDT
NetworkManager-openvpn-0.7.0-13.svn3632.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-06-16 19:31:55 EDT
NetworkManager-openvpn-0.7.0-13.svn3632.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5371
Comment 8 Fedora Update System 2008-06-22 16:44:35 EDT
NetworkManager-openvpn-0.7.0-13.svn3632.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Teguh DC 2008-06-22 20:21:16 EDT
after update to NetworkManager-openvpn-0.7.0-13.svn3632.fc9, my vpn is broken.
prev version is better than this.
using standar gateway port get same error.

error msg:
Jun 23 06:57:31 foutain nm-openvpn[3151]: script failed: shell command exited
with error status: 1
Comment 10 Christoph Höger 2008-06-23 09:59:07 EDT
It seems definitely to be some openvpn weirdness.
See #452506
Comment 11 Anthony Rumble 2008-06-24 03:19:11 EDT
Ditto. I just upgraded to -13 and it also broke my VPN

Jun 24 17:05:11 localhost nm-openvpn[28429]: script failed: shell command exited
with error status: 1
Comment 12 Bjoern 2008-06-24 04:32:45 EDT
same here. After the update to NetworkManager-openvpn-0.7.0-13.svn3632.fc9 my
VPN is broken too.

I'm using "X.509 with password authentification"

The Advanced options are:
use cipher: AES-256-CBC
use LZO compression
Comment 13 Fedora Update System 2008-06-24 06:28:50 EDT
NetworkManager-openvpn-0.7.0-14.svn3632.fc9 has been submitted as an update for Fedora 9
Comment 14 Christian Paratschek 2008-06-24 06:33:12 EDT
Same here: the new version 3632 broke my VPN via NetworkManager. Errormessage by
NM is:

The VPN connection "Server" failed because the VPN service stopped unexpectedly
Comment 15 Carl Roth 2008-06-24 17:10:00 EDT
Thanks!  Build 14 appears to fix the regression.
Comment 16 Fedora Update System 2008-06-24 22:51:29 EDT
NetworkManager-openvpn-0.7.0-14.svn3632.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Teguh DC 2008-06-25 22:20:13 EDT
great, my vpn running again.
Comment 18 Robert Hancock 2008-07-17 23:34:06 EDT
Problem is still not fixed for me with NetworkManager-openvpn-0.7.0-14.svn3632.fc9:

Jul 17 21:30:55 Dothan nm-openvpn[2831]:
/usr/bin/nm-openvpn-service-openvpn-helper "tun0" 1500 1544 192.168.233.78
192.168.233.77 init
Jul 17 21:30:55 Dothan nm-openvpn[2831]: script failed: shell command exited
with error status: 1

Isn't there some way to view the actual openvpn output to see what it is
complaining about?
Comment 19 Dan Williams 2008-09-30 16:06:41 EDT
Robert: can you try latest F8/F9 updates?  Should be svn4027 or later.

Note You need to log in before you can comment on or make changes to this bug.