Bug 446347 - openser-acc_radius - not found in module <acc>
openser-acc_radius - not found in module <acc>
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openser (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 04:12 EDT by Simon J Xuereb
Modified: 2008-05-19 04:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 04:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openser configuration file (3.87 KB, application/octet-stream)
2008-05-16 04:31 EDT, Simon J Xuereb
no flags Details
openser dictionary (3.91 KB, application/octet-stream)
2008-05-16 04:31 EDT, Simon J Xuereb
no flags Details
radiusclient.conf (2.71 KB, application/octet-stream)
2008-05-16 04:33 EDT, Simon J Xuereb
no flags Details
radiusclient.conf (2.71 KB, application/octet-stream)
2008-05-16 04:46 EDT, Simon J Xuereb
no flags Details
servers file (142 bytes, text/plain)
2008-05-16 04:47 EDT, Simon J Xuereb
no flags Details
Revised openser dictionary (3.91 KB, application/octet-stream)
2008-05-16 05:23 EDT, Simon J Xuereb
no flags Details

  None (edit)
Description Simon J Xuereb 2008-05-14 04:12:04 EDT
Description of problem:

Installed using "yum install openser-acc_radius.i386"

However parameters

modparam("acc", "radius_config", "/etc/radiusclient-ng/radiusclient.conf")
modparam("acc", "radius_flag", 1)
modparam("acc", "radius_missed_flag", 2)

are giving errors example:

May 14 11:40:48 [32394] ERROR:core:set_mod_param_regex: parameter
<radius_config> not found in module <acc>

I have also loaded module acc_radius.so and also tried parameters(just in case) 

modparam("acc_radius", "radius_config", "/etc/radiusclient-ng/radiusclient.conf")
modparam("acc_radius", "radius_flag", 1)
modparam("acc_radius", "radius_missed_flag", 2)

module seems to be totally ignored.

Version-Release number of selected component (if applicable):

openser-acc_radius-1.3.1-2.fc8

How reproducible:

Tried on 2 different Fedora 8 ( with all updates ) and reproduced the same results.

Steps to Reproduce:

loadmodule "acc_radius.so"
loadmodule "acc.so"

modparam("acc", "radius_config", "/etc/radiusclient-ng/radiusclient.conf")
modparam("acc", "radius_flag", 1)
modparam("acc", "radius_missed_flag", 2)
  
Actual results:

May 14 12:09:30 [32516] ERROR:core:set_mod_param_regex: parameter
<radius_config> not found in module <acc>
May 14 12:09:30 [32516] CRITICAL:core:yyerror: parse error in config file, line
54, column 20-21: Can't set module parameter
May 14 12:09:30 [32516] ERROR:core:set_mod_param_regex: parameter <radius_flag>
not found in module <acc>
May 14 12:09:30 [32516] CRITICAL:core:yyerror: parse error in config file, line
55, column 19-20: Can't set module parameter
May 14 12:09:30 [32516] ERROR:core:set_mod_param_regex: parameter
<radius_missed_flag> not found in module <acc>
May 14 12:09:30 [32516] CRITICAL:core:yyerror: parse error in config file, line
56, column 19-20: Can't set module parameter

Expected results:

Working normally.

Additional info:

I am not sure if the above error is actually a bug. But it seems the module is
totally being ignored.
Comment 1 Peter Lemenkov 2008-05-14 05:50:12 EDT
If you using acc_radius module then you mustn't include acc module. Please,
comment out loadmodule "acc.so" and repeat.
Comment 2 Simon J Xuereb 2008-05-14 08:32:32 EDT
When i comment #acc.so I get the following results.

May 14 16:26:23 [22664] ERROR:acc:init_acc_rad: acc: can't get code for the
Sip-Response-Code attribute
May 14 16:26:23 [22664] ERROR:acc:mod_init: failed to init radius
May 14 16:26:23 [22664] ERROR:core:init_mod: failed to initialize module acc
May 14 16:26:23 [22664] ERROR:core:main: error while initializing modules


I also upgraded to Fedora 9 now and still get the same results.
Comment 3 Peter Lemenkov 2008-05-14 08:44:39 EDT
Looks like you provided wrong radius-config.
Comment 4 Simon J Xuereb 2008-05-16 04:31:01 EDT
Created attachment 305656 [details]
openser configuration file
Comment 5 Simon J Xuereb 2008-05-16 04:31:58 EDT
Created attachment 305657 [details]
openser dictionary
Comment 6 Simon J Xuereb 2008-05-16 04:33:14 EDT
Created attachment 305659 [details]
radiusclient.conf
Comment 7 Simon J Xuereb 2008-05-16 04:41:46 EDT
Hi I moved on from the issue above using attached dictionary.openser.

However now during openser registration I am not seeing any incoming radius
requests (totally blank )in 

/usr/sbin/radiusd -X

my freeradius( localhost 1812,1813 ) + ldap was successfully tested using
NTRadPing and my /etc/raddb/clients.conf should be ok for localhost.

I have also noticed /usr/sbin/radclient is no longer present and
/usr/sbin/radiusclient is found instead when installing radiusclient-ng. 

Attached are my 3 configuration files.

Could radclient be the problem ?

10x for your help.

Regards

SJX
Comment 8 Simon J Xuereb 2008-05-16 04:46:19 EDT
Created attachment 305660 [details]
radiusclient.conf
Comment 9 Simon J Xuereb 2008-05-16 04:47:45 EDT
Created attachment 305662 [details]
servers file
Comment 10 Simon J Xuereb 2008-05-16 04:49:01 EDT
updated radiusclient.conf / servers file. 

10x again

SJX
Comment 11 Peter Lemenkov 2008-05-16 05:11:37 EDT
With attached dictionary file I've got the following errors:

May 16 13:02:20 dev /usr/sbin/openser[32682]: INFO:acc:mod_init: initializing... 
May 16 13:02:20 dev /usr/sbin/openser[32682]: ERROR:acc:init_acc_rad: acc: can't
get code for the User-Name attribute 
May 16 13:02:20 dev /usr/sbin/openser[32682]: ERROR:acc:mod_init: failed to init
radius 
May 16 13:02:20 dev /usr/sbin/openser[32682]: ERROR:core:init_mod: failed to
initialize module acc 
May 16 13:02:20 dev /usr/sbin/openser[32682]: ERROR:core:main: error while
initializing modules 

Although your exact message wasn't tracked, looks like you provided incomplete
dictionary.
Comment 12 Simon J Xuereb 2008-05-16 05:23:32 EDT
Created attachment 305664 [details]
Revised openser dictionary

Uncommented a few lines. It should work now.

10x

SJX

Note You need to log in before you can comment on or make changes to this bug.