Bug 446376 - sudo strips leading slashes of paths passed to vim
sudo strips leading slashes of paths passed to vim
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 07:52 EDT by John Florian
Modified: 2008-07-08 08:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.6.9p13-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 08:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Florian 2008-05-14 07:52:56 EDT
Description of problem:
If a sudo is used to launch vim against several files, only the first path 
name remains unmangled.  All other paths passed to vim will have leading slash 
stripped.

Version-Release number of selected component (if applicable):
sudo-1.6.9p4-6.fc8
vim-7.1.245-1.fc8

How reproducible:
sudo vim /etc/hosts /etc/services

Steps to Reproduce:
1. Run above command.
2. First file (/etc/hosts) will load just fine.
3. Tell vim to load next file (/etc/services) using ':n'.
  
Actual results:
Next file (/etc/services) will not load because vim will actually be trying to 
load 'etc/services'.

Expected results:
vim should have no problem loading 2nd file in example.

Additional info:
This example works just fine without sudo and also works fine as root via su.  
I have not seen the problem with any other command other than vim.
Comment 1 Peter Vrabec 2008-07-08 08:38:34 EDT
fixed in 1.6.9p13-5

Note You need to log in before you can comment on or make changes to this bug.