Bug 44639 - problems with standby and suspend
Summary: problems with standby and suspend
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-14 21:34 UTC by Jun Pan
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-14 21:34:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jun Pan 2001-06-14 21:34:22 UTC
Description of Problem:

I am an IBM X21 with RedHat 7.1 installed. 

1) If I put the machine to a standby, after waking up from a standy by, I
get this message:
   kernel: ide_dmaproc: shipset supported ide_dma_lostirq func only: 13
   kernel: hda: lost interrupt

2) If I put the machine to a suspend, it will never wake up, and I have to
reboot

How Reproducible:
very

Steps to Reproduce: (as described above)
1. 
2. 
3. 
 
Actual Results: (as described above)


Expected Results:


Additional Information:

Comment 1 Bernhard Rosenkraenzer 2001-06-26 16:46:09 UTC
BIOS bug or hardware bug.

Try setting
HDPARM_AT_SUSPEND="-q -X0 -q c0 -q d0 -q -u0 -q -S0"
in /etc/sysconfig/apm

This workaround is sufficient for most (but not all) broken BIOSes, 
controllers and disks.



Comment 2 Jun Pan 2001-06-26 16:52:53 UTC
Yes, I tried that, but didn't work!

Comment 3 Bernhard Rosenkraenzer 2001-06-26 16:54:33 UTC
Then there's nothing we can do about it - ask the manufacturer to fix up their 
BIOS or hardware.


Comment 4 Jun Pan 2001-06-26 17:53:46 UTC
I ran win2000 under the same machine, and never ran into suspend/standby
problem.  Why would the manufactor change their BIOS just for LINUX?  It is
people like you and attitude like yours that make LINUX always a SECONDARY
operating system.


Note You need to log in before you can comment on or make changes to this bug.