Bug 446433 - cifs mount to Windows share requires use of path with echoes of directory
cifs mount to Windows share requires use of path with echoes of directory
Status: CLOSED DUPLICATE of bug 431868
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.1
i686 Linux
low Severity low
: rc
: ---
Assigned To: Jeff Layton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 12:11 EDT by Donald Teed
Modified: 2014-06-18 03:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 12:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Teed 2008-05-14 12:11:07 EDT
Description of problem:

Windows server 2003 RC2 has a share we can successfully mount from RHEL 5.
However the expected path location is wrong.  The directory name is echoed
in subdirectories under the mount point, and again in the directory under
that.  Where I expect to find a file in /mountpoint/user/filename.txt
it actually appears under /mountpoint/user/user/user/filename.txt

This problem appeared after updates to kernel and samba around March 2008.
The bug was reproduced on a test server.  Then I saw it was not reproduced on
a fresh install of RH 5.1 on a 2nd test server.  Then these packages were
applied on the first test server to force a downgrade to the package
versions on the CDROM:

apr-devel-1.2.7-11.i386.rpm
apr-util-devel-1.2.7-6.i386.rpm
gcc-4.1.1-52.el5.i386.rpm
gcc-c++-4.1.1-52.el5.i386.rpm
gcc-gfortran-4.1.1-52.el5.i386.rpm
glibc-2.5-12.i386.rpm
glibc-2.5-12.i686.rpm
glibc-common-2.5-12.i386.rpm
glibc-devel-2.5-12.i386.rpm
glibc-headers-2.5-12.i386.rpm
httpd-2.2.3-6.el5.i386.rpm
httpd-devel-2.2.3-6.el5.i386.rpm
kernel-2.6.18-8.el5.i686.rpm
kernel-headers-2.6.18-8.el5.i386.rpm
samba-client-3.0.23c-2.i386.rpm
samba-common-3.0.23c-2.i386.rpm
systemtap-0.5.12-1.el5.i386.rpm
systemtap-runtime-0.5.12-1.el5.i386.rpm

After rebooting with the 2.6.18-8 kernel, the mount point is working as expected
with the result at /mountpoint/user/filename.txt .

With the 2.6.18-53.1.13.el5 kernel, and 3.0.25b-1 samba client, the mount point
contains the user directory name echoed 3 deep.

Version-Release number of selected component (if applicable):
samba-client-3.0.25b-1.el5_1.4
kernel-2.6.18-53.1.14.el5

A test kernel was also made with 2.6.18-53.1.19 which included smbfs
support.  When the mount was made via smbfs, the echo of the user
directory is not present.

How reproducible:

This was reproduced on an x86_64 server with 2.6.18-53.1.14.el5,
as well as an x86 server with 2.6.18-53.1.19.el5 kernel.

Steps to Reproduce:
1. Using kernel-2.6.18-53.1.14.el5 and samba-client-3.0.25b-1.el5_1.4 
2. mount /home/www (from fstab):  
//winserver.mydomain.ca/Users      /home/www       cifs   
credentials=/root/web_credentials,ro,uid=apache,gid=apache,dir_mode=0550,file_mode=0550
0 0
3. ls /home/www/username ; ls /home/www/username/username
  
Actual results:

Is see files at the /mountpoint/user/user/user/filename.txt
level.

Expected results:

I expect to see files at the /mountpoint/user/filename.txt
level.

Additional info:

Let me know if you need anything more for data...
Comment 1 Donald Teed 2008-11-03 08:49:52 EST
This issue has been pursued with Redhat Support.

We found the bug went away with a test kernel due out with RH 5.3

The Case number was 1827704 if you'd like to see the details of
the debugging.
Comment 2 Jeff Layton 2008-11-04 12:00:26 EST
Excellent. Sounds like this is probably a duplicate of bug 431868. I'm going to close this as such. If it turns out that 5.3 doesn't fix it, then please reopen the case.

*** This bug has been marked as a duplicate of bug 431868 ***

Note You need to log in before you can comment on or make changes to this bug.