Bug 446466 - kcontrol modules appearing in gnome "Other" menu
kcontrol modules appearing in gnome "Other" menu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase3 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 13:57 EDT by Rex Dieter
Modified: 2008-06-06 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.5.9-14.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdelibs-3.5.9-kcmultidialog-ignore-nodisplay.patch (487 bytes, patch)
2008-05-15 14:54 EDT, Kevin Kofler
no flags Details | Diff
kdelibs-3.5.9-kcmultidialog-ignore-nodisplay.patch rev2 (1.31 KB, patch)
2008-05-15 15:51 EDT, Kevin Kofler
no flags Details | Diff
OnlyShowIn=KDE3 support for KService, KServiceGroup (1.65 KB, patch)
2008-05-15 16:11 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Rex Dieter 2008-05-14 13:57:09 EDT
kdebase3's kcontrol modules are appearing in gnome's "Other" menu.  Pretty crappy.

Not sure why this didn't happen in f8. ?? (or maybe it did).
Comment 1 Julian Sikorski 2008-05-14 13:58:54 EDT
It didn't happen in my system, and I did an anaconda upgrade.
Comment 2 Rex Dieter 2008-05-14 14:10:24 EDT
For example,
/usr/share/applications/kde/colors.desktop
/usr/share/applications/kde/fonts.desktop
include
Hidden=true;

But, these *do* get hidden with
Hidden=true
(sans ;)

I'll have to go check the spec to see if it covers the ;
Comment 3 Rex Dieter 2008-05-14 14:14:11 EDT
Ugh, looks like ; shouldn't be there:

http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html

"Some keys can have multiple values. In such a case, the value of the key is
specified as a plural: for example, string(s). The multiple values should be
separated by a semicolon. Those keys which have several values should have a
semicolon as the trailing character. Semicolons in these values need to be
escaped using \;."
Comment 4 Rex Dieter 2008-05-14 14:23:20 EDT
OK, found it, 
kdebase3.spec:
perl -pi -e "s,OnlyShowIn=KDE,Hidden=true," *
Comment 5 Fedora Update System 2008-05-14 15:46:45 EDT
kdebase3-3.5.9-11.fc9 has been submitted as an update for Fedora 9
Comment 6 Rex Dieter 2008-05-15 09:36:11 EDT
update revoked, turns out
Hidden=true
breaks kcmshell.  Kevin's looking into it.
Comment 7 Ngo Than 2008-05-15 12:32:18 EDT
imo it doesn't make sense to show the kcontrol modules in other desktops. We 
just let the default upstream setting in desktop files. 
Comment 8 Rex Dieter 2008-05-15 12:36:14 EDT
In particular, we don't even want to see any kde3 kcontrol modules on KDE4
desktop either.

One reason why I had a quick braindump to support something like
OnlyShowIn=KDE3
Comment 9 Kevin Kofler 2008-05-15 12:39:26 EDT
The point of using Hidden=True rather than OnlyShowIn=KDE is that we don't want 
these things to show up in the KDE 4 menus either.

Rex, can you try NoDisplay=True instead of Hidden=True? Hidden essentially 
means this is deleted entirely, which is probably why it breaks kcmshell. 
NoDisplay is what should be used to hide things:
http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html#recognized-keys
Comment 10 Ngo Than 2008-05-15 12:49:14 EDT
it's correct, NoDisplay=true should work. it's what we need.
Comment 11 Rex Dieter 2008-05-15 13:23:32 EDT
NoDisplay=true is better, but still doesn't work right.
$ kcmshell proxy
shows a window now, except it is blank.
Comment 12 Kevin Kofler 2008-05-15 13:30:04 EDT
Argh, I'll try to fix the code. NoDisplay=true should be the right thing to 
use.
Comment 13 Kevin Kofler 2008-05-15 14:54:51 EDT
Created attachment 305521 [details]
kdelibs-3.5.9-kcmultidialog-ignore-nodisplay.patch

Can you please try this (trivial) kdelibs3 patch?
Comment 14 Kevin Kofler 2008-05-15 14:58:48 EDT
Another thing worth trying would be if OnlyShowIn=KDE3 doesn't actually do the 
right thing there. Or even OnlyShowIn=asdfgh for that matter. ;-)
Comment 15 Rex Dieter 2008-05-15 15:47:53 EDT
bad news: patch doesn't work, nor does OnlyShowIn=KDE3
both (still) result in a blank window. 
Comment 16 Kevin Kofler 2008-05-15 15:51:19 EDT
Created attachment 305532 [details]
kdelibs-3.5.9-kcmultidialog-ignore-nodisplay.patch rev2

Another try.
Comment 17 Kevin Kofler 2008-05-15 16:11:43 EDT
Created attachment 305537 [details]
OnlyShowIn=KDE3 support for KService, KServiceGroup

> One reason why I had a quick braindump to support something like
> OnlyShowIn=KDE3

This patch adds that to KService and KServiceGroup. (For future reference:
OnlyShowIn is also used in kdelibs/autostart, kdebase/kdesktop and
kdebase/libkonq, if we want full support for this feature, those are the places
to patch too.)
Comment 18 Fedora Update System 2008-05-17 18:24:59 EDT
kdebase3-3.5.9-14.fc9, kdelibs3-3.5.9-11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase3 kdelibs3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4089
Comment 19 Fedora Update System 2008-06-06 03:46:01 EDT
kdelibs3-3.5.9-14.fc9, kdebase3-3.5.9-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.