Bug 446468 - Mylyn unresolved dependencies
Mylyn unresolved dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 14:07 EDT by István Tóth
Modified: 2008-05-28 22:50 EDT (History)
0 users

See Also:
Fixed In Version: 2.3.2-6.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 22:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description István Tóth 2008-05-14 14:07:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-mylyn-2.3.2-4.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum groupinstall "Fedora Eclipse"
2. start eclipse
3. Help->Software updates->Find and Install->Search for new...
4. Choose any of the default repositories, or add any new one
5. Select some features
6. Click "Error Details"
  
Actual results:

(Shortened, because I can't cut'n'paste from the error window)
--------------------------------------------------------------------------
Mylyn Bridge: Eclipse IDE (2.3.2.200804151252) requires feature
"org.eclipse.mylyn.context_feature (2.3.2.qualifier)", or compatible.
Mylyn connectore: Bugzilla ...same...
Mylyn Focused UI (Recommended) ...same..
Mylyn Bridge: Java Development ...same...
-------------------------------------------------------
and I can't install any new software via the updates mechanism.

Expected results:

No dependency errors in the RPM installed packages, and being able to install
external features.

Additional info:

I've had the same results, one with a clean install, one with a thoroughly
cleaned eclipse environment (.eclipse, workspace deleted, libraries cleared).

Removing all eclipse-mylyn-* rpm packages, as well as the eclipse-pydev rpm
package solves the problem, so I'm quite confident, that the problem is in the
rpm pacakging of the mylyn module.
Comment 1 Andrew Overholt 2008-05-14 14:14:53 EDT
You are correct.  I just noticed this myself and will try to fix ASAP.  Sorry
about this.
Comment 2 Andrew Overholt 2008-05-14 15:58:46 EDT
This has to do with https://bugs.eclipse.org/bugs/show_bug.cgi?id=108291 (they
now have a build system that automatically inserts the version for
".qualifier").  I've asked for a link to the doc that explains how it works so
we can duplicate.
Comment 3 Fedora Update System 2008-05-20 09:44:33 EDT
eclipse-mylyn-2.3.2-6.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-21 07:09:28 EDT
eclipse-mylyn-2.3.2-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse-mylyn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4292
Comment 5 Andrew Overholt 2008-05-26 11:07:41 EDT
Hi István,

Do you think you could try out this update and verify that it works?  It does
for me.  If you can confirm, I'll put it as a stable update.

Thanks,

Andrew
Comment 6 István Tóth 2008-05-27 02:04:40 EDT
I've just installed it, and I no longer get the dependency errors.
(I do not actually use the functionality, so I can not comment on that)
Seems O.K. to me.

regards
István
Comment 7 Fedora Update System 2008-05-28 22:50:42 EDT
eclipse-mylyn-2.3.2-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.