Bug 446477 - Selecting bind-chroot during install not executed properly
Selecting bind-chroot during install not executed properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 15:12 EDT by Mike C
Modified: 2013-04-30 19:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 9.5.0-32.rc1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 03:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
install.log as requested (61.20 KB, text/plain)
2008-05-15 04:05 EDT, Mike C
no flags Details

  None (edit)
Description Mike C 2008-05-14 15:12:48 EDT
Description of problem:

During F9 install from DVD iso file on hard drive bind-chroot was selected as
one of the packages to install. However the correct set of files was not
installed into /var/named/chroot/etc/ or /var/named/chroot/var/named/ and the
symlink from /etc/named.conf was not made. 

However once the system was running after install doing
yum remove bind-chroot
followed by
yum install bind-chroot
did install the correct files and links using the manual re-install.

Version-Release number of selected component (if applicable):
Anaconda as per DVD install iso - Fedora-9-i386-DVD.iso 
bind-chroot bind-chroot-9.5.0-29.b2.fc9.i386


How reproducible: Same behaviour on two different installs with the same method.


Steps to Reproduce:
1. Install F9 from DVD iso and include bind-chroot in package selection
2. On running system check files in /var/named/chroot/ incorrect
3. do yum remove bind-chroot
4. do yum install bind-chroot
5. Now check files in bind chrooted directory are correct and the symlink
from /etc/named.conf has been created correctly. bind-chroot now works.
  
Actual results:bind-chroot is not instaled correctly during install.


Expected results:bind-chroot should install correctly if selected as one of the
packages to install from the install media (DVD iso)


Additional info:Tested on two different installs, and install iso tested for
sha1sum verification ok.
Comment 1 Chris Lumens 2008-05-15 00:21:40 EDT
Please attach /root/install.log to this bug report.  Sounds like a bind
packaging problem, perhaps.
Comment 2 Mike C 2008-05-15 04:05:51 EDT
Created attachment 305451 [details]
install.log as requested

It certainly seems there was a problem with bind-chroot during install with
warnings about user/group "named" not existing.
Comment 3 Paul Howarth 2008-05-18 10:29:32 EDT
(In reply to comment #2)
> It certainly seems there was a problem with bind-chroot during install with
> warnings about user/group "named" not existing.

This will be because bind-chroot has no dependency on bind; it should have one
to provide the "named" account.
Comment 4 Adam Tkac 2008-05-20 10:49:28 EDT
Yes, that dependency was mysteriously dropped, not sure why.
Comment 5 Fedora Update System 2008-05-23 07:14:27 EDT
bind-9.5.0-32.rc1.fc9 has been submitted as an update for Fedora 9
Comment 6 Mike C 2008-05-23 13:14:20 EDT
Excellent on the update though of course this will hit anyone installing off the
original install media, unless there is a re-spin later that people use instead.

Perhaps a comment can be added to the release notes if an updated version is
made, to warn anyone installing from the original files with no internet
connection that they need to install bind-chroot after the install is complete,
rather than including it in the package list on the original install?
Comment 7 Fedora Update System 2008-05-28 22:52:23 EDT
bind-9.5.0-32.rc1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4644
Comment 8 Fedora Update System 2008-06-03 03:28:26 EDT
bind-9.5.0-32.rc1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.