Bug 446478 - Unable to bind keyboard shortcut to "Open A Terminal" (while others work as expected)
Unable to bind keyboard shortcut to "Open A Terminal" (while others work as e...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 15:13 EDT by jon
Modified: 2009-12-13 17:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:48:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jon 2008-05-14 15:13:48 EDT
Description of problem:

Unable to bind keys to "Open a Terminal" under keyboard shortcut.  

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Very

Steps to Reproduce:
1.Go to System->Preferences->Personal->Keyboard Shortcuts
2.Go to "Open A Terminal" and enter a keyboard shortcut
3.Try to use the keyboard shortcut (won't work)
4.Go back into Keyboard Shortcuts and assign that same keyboard shortcut to
something else ("Run An Application" for example)
5.Press the keyboard shortcut (notice that it *does* work)

Actual results:
Shortcut does not work for that one specific item in keyboard shortcuts

Expected results:
Expect keyboard shortcut to launch a terminal

Additional info:
Comment 1 Toshio Ernie Kuratomi 2008-05-14 15:39:14 EDT
gnome-common provides development files for programmers developing and building
GNOME software.  Reassigning to control-center which provides

System->Preferences->Personal->Keyboard Shortcuts
Comment 2 Bastien Nocera 2008-05-14 15:58:08 EDT
Works here. What terminal is selected in the preferred applications? Is the
terminal you selected actually available?
Comment 3 jon 2008-05-14 16:12:39 EDT
I'm not sure.  I'm binding the keyboard shortcut to the "Open A Terminal" option
under Keyboard Shortcuts under the "Desktop" section.

I'm able to go to Applications -> System Tools -> Terminal and open a terminal
if that helps at all.

Sorry if I'm not much help.

Also, I posted a thread on fedoraforum.org and only got one response but they
confirmed the same behavior:

http://forums.fedoraforum.org/forum/showthread.php?t=188303
Comment 4 Bastien Nocera 2008-05-14 16:49:33 EDT
(In reply to comment #3)
> I'm not sure.  I'm binding the keyboard shortcut to the "Open A Terminal" option
> under Keyboard Shortcuts under the "Desktop" section.

Which terminal did you choose under the Preferred applications:
System -> Preferences -> Personal -> Preferred applications
?

Which keyboard shortcut are you trying to assign to the command?
Comment 5 jon 2008-05-14 17:30:46 EDT
"Which terminal did you choose under the Preferred applications: System ->
Preferences -> Personal -> Preferred applications?"

I'm using "Gnome Terminal" (Haven't changed it)

"Which keyboard shortcut are you trying to assign to the command?"

I've tried several.  I started with windows key + t, but even after adjusting
the Alt/Win key behavior it still wasn't working, so then I tried
ctrl+alt+enter, which also didn't work.  Then I bound ctrl+alt+enter to "Run
Dialog" and it worked fine.
Comment 6 jon 2008-05-14 17:43:08 EDT
From the fedora forum thread:

"maybe it's gnome's 2.20 bug, because I've checked that in gnome 2.22 and it
worked well"

I'm running 2.20.3 build date of 1/8/08 if that helps at all.
Comment 7 jon 2008-05-16 10:33:00 EDT
If I disable desktop effects the keyboard shortcut works.  Reenabling the
desktop effects causes it to stop working again.
Comment 8 Bastien Nocera 2008-05-16 10:54:37 EDT
Compiz bug then (which probably has a hard-coded terminal to use, or doesn't
follow the gnome settings for the preferred terminal).
Comment 9 Bug Zapper 2008-11-26 05:42:30 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-01-09 02:48:47 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 11 Earth 2009-12-13 17:38:44 EST
I observe this bug in Fedora 12 (only after installing Compiz).


Dismissing bugs after 18 months by automatic process is dumb. 18 months is not a long duration compared to the lifespan of most software in Fedora. It is naive to assume that in this time a developer will have edited the offending line[s] of code among many thousands and happened to fix the bug of which he was not aware. Time is no great healer for software (Firefox has bugs reproducible today that were reported in Mozilla last century), instead bugs are fixed when users inform developers about them and provide instructions to reproduce them (this is why we have a bugtracker). 

I suggest that after 18 months it is tested whether a bug can still be reproduced, then either closed or relabelled as applying to the current release to stimulate fixing.

A bug reported is an opportunity to improve the quality of software in Fedora, we should not dismiss it without inspection.
Comment 12 Earth 2009-12-13 17:44:26 EST
I removed compiz and compiz-gnome. Now "open a terminal" isn't even listed in the list of keyboard shortcuts (gnome-keybinding-properties). Here is a screenshot: http://i.imgur.com/V2ux2.png

Steps taken:
1: Install Fedora 12  (at this point, keyboard shortcut can be set and works correctly)
2: Install compiz (keyboard shortcut can be set but does not work)
3: Remove compiz (keyboard shortcut is not even listed)

Note You need to log in before you can comment on or make changes to this bug.