Bug 446484 - Amarok cannot use system-wide proxy settings in GNOME or environment
Amarok cannot use system-wide proxy settings in GNOME or environment
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kdebase3 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 16:01 EDT by Linus Walleij
Modified: 2009-01-09 15:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 15:41:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Walleij 2008-05-14 16:01:06 EDT
Description of problem:
Trying to get Amarok, which is installed under GNOME, to submit playcounts to
last.fm using a proxy server. This does not work. It does not respect the
system-wide setting in gnome-network-preferences, nor does it respect the
environment variables HTTP_PROXY or http_proxy (neither upper or lower case).

According to the documentation Amarok use the settings from KDE kcontrol, but I
don't have KDE, and I expect it to atleast fall back to HTTP_PROXY settings if
it cannot use the GNOME stuff. (Which I do understand is not a priority for Amarok.)


Version-Release number of selected component (if applicable):
amarok-1.4.8-5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Play songs in Amarok behind a proxy, set proxy to something
2. Reload your last.fm page after playing some songs
  
Actual results:
No playcounts reported, Amarok also says it fails.

Expected results:
Respect some system-wide proxy and submit the playcounts.
Comment 1 Rex Dieter 2008-05-14 16:12:59 EDT
afaik, gnome-network-preferences is gnome-specific, and there doesn't exist
anything akin to a system-wide proxy (maybe HTTP_PROXY?  I'll have to
double-check that).

Normally, I'd say just recommend:
yum install kdebase3
kcmshell proxy
to configure kde3's proxy settings, but it would appear we omitted the proxy
module from kdebase3.
Comment 2 Kevin Kofler 2008-05-14 16:26:58 EDT
Using the GNOME preferences is not going to happen.

As for HTTP_PROXY, the problem is that there are many proxy configurations this 
simple environment variable just cannot candle. But I guess it would be worth 
interpreting this if it's set. I doubt this is going to happen in the KDE 3 
libs though.

(By the way, no need to rant about KDE 4's proxy support or lack thereof, we 
already have 2 bug reports for that. ;-) Let's keep this about KDE 3 
libs/apps.)
Comment 3 Linus Walleij 2008-05-14 19:03:25 EDT
(In reply to comment #1)

> afaik, gnome-network-preferences is gnome-specific,

I know...

> and there doesn't exist
> anything akin to a system-wide proxy (maybe HTTP_PROXY?  I'll have to
> double-check that).

That's more or less de facto, for example yum respects HTTP_PROXY.

> Normally, I'd say just recommend:
> yum install kdebase3
> kcmshell proxy
> to configure kde3's proxy settings, but it would appear we omitted the proxy
> module from kdebase3.

Is there a separate bug for that?

And shouldn't Amarok Requires: kdebase3 in that case?
Comment 4 Kevin Kofler 2008-05-14 19:27:26 EDT
I'll see what it takes to reenable kcm_proxy, I know at least one application 
which wants to display it as part of its UI (ktigcc at repo.calcforge.org), and 
it'll also help with this bug.
Comment 5 Kevin Kofler 2008-05-14 19:35:36 EDT
I just checked and it's there. proxy.desktop is installed and kcm_kio.so, which 
contains the KCM, is present. Doesn't:
kcmshell proxy
work?
Comment 6 Rex Dieter 2008-05-15 00:35:35 EDT
I tried, 'kcmshell proxy' did nothing for me.
Comment 7 Kevin Kofler 2008-05-15 00:41:32 EDT
MathStuf tested this (also on F9) and "kcmshell proxy" worked for him. Did you 
try this before or after your latest change to kdebase3 which correctly sets 
those .desktop files to hidden? (I'm asking because maybe that's breaking 
kcmshell too.)
Comment 8 Rex Dieter 2008-05-15 08:29:33 EDT
ok, kcmshell not working must be just me... I can't seem to get any kde3 kcm's
to work on my box.

So, is there anything more to this than suggesting:
yum install kdebase3
kcmshell proxy
?
Comment 9 Linus Walleij 2008-05-15 11:31:04 EDT
Nothing happens on my boxen when typing "kcmshell proxy" either. I tried

kcmshell proxy http://www-proxy....:8080

believing it perhaps sets variables, but needless to say, this didn't work
either. Som HOWTO would be great here.
Comment 10 Kevin Kofler 2008-05-15 11:38:31 EDT
What version of kdebase3 do you have (output of rpm -q kdebase3)? If none at 
all, install it and try again.
Comment 11 Linus Walleij 2008-05-16 03:31:02 EDT
Yep installing kdebase3 makes it possible to run "kcmshell proxy" which
can be configured correctly and this solves the problem! Songcounts are
now submitted properly.

I missed kdebase3 since kcmshell was present (comes from kdelibs3, required
by Amarok.)

Does this boil down to the fact that the package amarok should acually:

Requires: kdebase3

to be fully functional? Not that I know if users of Amarok not using KDE
would understand this quite complex procedure, but anyway...
I think most programs respect HTTP_PROXY so I still believe this could be
fixed, if you have a pointer into the Amarok source code where proxy
is read up I could take a stab at fixing and testing this.
Comment 12 Rex Dieter 2008-05-16 07:45:11 EDT
Depends on your definition/notion of "fully funtional".  This is a truly
optional piece of kde functionalility and infrastructure, so would be hesitant
to force it on everyone via a hard Requires.
Comment 13 Kevin Kofler 2008-05-16 09:14:59 EDT
IMHO the right fix would be for KDE 3 to understand KDE 4's proxy settings (if 
this isn't already the case, has anybody tried how setting them in one KDE 
version affects the other?), not GNOME's or some environment variable's.
Comment 14 Steven M. Parrish 2008-07-17 16:03:49 EDT
Still an issue or has it been resolved?  If not is it something we need to purse
with the impending 4.1 and Amarok2
Comment 15 Bug Zapper 2008-11-25 21:16:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Steven M. Parrish 2009-01-09 15:41:39 EST
The information we've requested above is required in order to review this problem report further and diagnose or fix the issue if it is still present.  Since it has been thirty days or more since we first requested additional information, we're assuming the problem is either no longer present in the current Fedora release, or that there is no longer any interest in tracking the problem.

Setting status to "CLOSED: INSUFFICIENT_DATA".  If you still experience this problem after updating to our latest Fedora release and can provide the information previously requested, please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.