Bug 446487 - innd segfaults at startup (libperl related)
innd segfaults at startup (libperl related)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 16:09 EDT by Lucas Maneos
Modified: 2008-05-21 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4.4-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 07:01:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (9.78 KB, application/octet-stream)
2008-05-14 16:09 EDT, Lucas Maneos
no flags Details

  None (edit)
Description Lucas Maneos 2008-05-14 16:09:25 EDT
Description of problem:

When starting innd the daemon dies with a segmentation fault.  Dmesg output shows:

kernel: innd[1037]: segfault at 0 ip 0020925b sp bf9444a0 error 4 in
libperl.so[12f000+26a000]

The sp number varies, but ip * libperl.so offset are always constant.

Version-Release number of selected component (if applicable):

inn-2.4.3-12.fc9.i386

How reproducible:

Every time.

Steps to Reproduce:
1. /etc/init.d/innd start
  
Actual results:

The init script reports OK, but innd has actually crashed.

Expected results:

Normal startup of innd.

Additional info:

This is a freshly-upgraded system, previously running F8 with
inn-2.4.3-9.fc8.i386, functioning normally.  I tried rebuilding the history &
overview but it hasn't made a difference.

I managed to strace it using the  in
<http://www.eyrie.org/~eagle/faqs/inn.html#S3.6>, attaching the output
(segmentation fault is at line 639).
Comment 1 Lucas Maneos 2008-05-14 16:09:25 EDT
Created attachment 305397 [details]
strace output
Comment 2 Tom Hughes 2008-05-16 19:16:11 EDT
I am also seeing this on an x86_64 system upgraded from Fedora 8.
Comment 3 Tom Hughes 2008-05-16 19:38:42 EDT
I have managed to get innd starting now by replacing
/usr/lib/news/bin/filter/startup_innd.pl with an empty file.
Comment 4 Lucas Maneos 2008-05-17 02:41:26 EDT
Confirmed (and thanks!), getting rid of the code in startup_innd.pl allows innd
to start here as well.
Comment 5 Lucas Maneos 2008-05-19 07:40:54 EDT
But it died again (same segfault details in dmesg) during Sunday's cron.daily :-(
Comment 6 Ondrej Vasik 2008-05-19 09:07:45 EDT
Thanks for report... What does rpm -q perl and rpm -V say? It seems to be some
issue with perl.
Comment 7 Ondrej Vasik 2008-05-19 09:08:36 EDT
(I meant rpm -V perl of course)
Comment 8 Lucas Maneos 2008-05-19 09:32:49 EDT
rpm -q perl: perl-5.10.0-20.fc9.i386
rpm -V perl: no output

According to <http://www.eyrie.org/~eagle/software/inn/docs-2.4/news.html#S1>,
Perl 5.10 support was added in 2.4.4.
Comment 9 Ondrej Vasik 2008-05-19 09:43:05 EDT
Thanks for that link and information, inn-2.4.4 was built in rawhide, so it does
mean that I have to build it for F9 as well ... Just to be sure that it will
solve troubles, could you please try those rawhide RPM's?
http://koji.fedoraproject.org/koji/buildinfo?buildID=49139
Comment 10 Lucas Maneos 2008-05-19 10:02:20 EDT
I built and installed 2.4.4-1 from inn-2.4.4-1.fc10.src.rpm (to avoid
introducing other variables) and it starts up fine and seems to work ok so far.
Comment 11 Ondrej Vasik 2008-05-19 10:08:14 EDT
Ok, thanks for quick reaction, will do an inn-2.4.4 update for F9 as otherwise
is the package useless with perl-5.10
Comment 12 Tom Hughes 2008-05-19 10:10:26 EDT
I've installed the rawhide binary and it starts for me with no segfault.
Comment 13 Fedora Update System 2008-05-19 10:55:43 EDT
inn-2.4.4-1.fc9 has been submitted as an update for Fedora 9
Comment 14 Fedora Update System 2008-05-21 07:01:23 EDT
inn-2.4.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.