Bug 446527 - no gateway route setup for network
no gateway route setup for network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 18:53 EDT by Tom Horsley
Modified: 2008-05-22 12:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 18:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/network-scripts/ifcfg-eth0 from sys with no DNS (273 bytes, text/plain)
2008-05-15 16:06 EDT, Tom Horsley
no flags Details
ifcfg-eth0 from fresh f9 install (270 bytes, application/octet-stream)
2008-05-16 02:24 EDT, Edouard Bourguignon
no flags Details
/etc/sysconfig/network (73 bytes, text/plain)
2008-05-19 13:42 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2008-05-14 18:53:26 EDT
Description of problem:

When I installed fedora 9, I told it to initialize the network at boot
time with a static address and provided all the info including the
default gateway (a linksys router) at 192.168.1.1.

When the system boots, there is no gateway in the route tables.
After booting, if I manually type:

ip route add default via 192.168.1.1

then I can get to the outside world (before that only local devices
on the 192.168.1.0/24 lan were talking).

Version-Release number of selected component (if applicable):

This is whatever was shipped with the fedora 9 x86_64 DVD image,
and I doubt system-config-network is even the right component, but I
have no idea what other component to report.

How reproducible:

Every time I boot.

Steps to Reproduce:
1. see above
  
Actual results:

no default gateway

Expected results:

default gateway

Additional info:

If I bring up the properties for the eth0 device in the network
config app, the gateway field does indeed have 192.168.1.1
in it, but it doesn't seem to actually take effect when the system
boots. If I run nm-tool, it shows eth0 with a 0.0.0.0 gateway.
Comment 1 Tom Horsley 2008-05-14 21:41:12 EDT
I just got the iproute-2.6.25-1.fc9.x86_64 update installed, and thought
that might have something to do with this bug, but when I rebooted,
I still had no route to my gateway :-(.
Comment 2 Tom Horsley 2008-05-15 08:35:59 EDT
On my machine at work, I also don't get DNS info in resolv.conf, even though
I specified it at installation time the same way I did when installing at
home. Disabling the NetworkManager service and enabling network instead
fixes everything. Maybe anaconda should just do that when you specify a
static IP?
Comment 3 Dan Williams 2008-05-15 14:40:48 EDT
Tom: installation with Anaconda within the past few weeks will write out the
correct DNS information to your ifcfg files, which will allow NetworkManager to
set up your DNS correctly.  NM handles static IPs and static DNS just fine as
long as anaconda writes out the stuff correctly.  I verified this yesterday with
a Fedora 9 Gold LiveCD install.

Could you attach your /etc/sysconfig/network-scripts/ifcfg-eth0 file so we can
see if it's set up correctly?
Comment 4 Tom Horsley 2008-05-15 16:06:05 EDT
Created attachment 305533 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0 from sys with no DNS

Here's the eth0 script from the system at work which had no DNS info.
I swear I put it in during install (which was using the i386 DVD image
from the official f9 release).

In fact, I must have put it in, because which I switched back to the
network script instead of NetworkManager, everything worked, so it did
have the info somewhere.
Comment 5 Edouard Bourguignon 2008-05-16 02:24:59 EDT
Created attachment 305634 [details]
ifcfg-eth0 from fresh f9 install

here is my ifcfg-eth0, static network configuration during install, and now no
default route on boot. Fix in Bug #446428 resolves the problem
Comment 6 Edouard Bourguignon 2008-05-16 02:28:35 EDT
mmm no doesn't really fix the problem, sorry, the network connection is messy,
some apps (firefox, packagekit) think the computer is offline. So i remove the
ifcfg-eth0 and now NetworkManager find the link and network is fine (not static
as i wish but I can wait till it get fixed)
Comment 7 Dan Williams 2008-05-19 12:57:42 EDT
I think the issue is a missing gateway in the ifcfg file, which is probably in
/etc/sysconfig/network actually.  I'll push an update to pull info from that
file if the ifcfg file doesn't have it.

Can you attach your /etc/sysconfig/network file?
Comment 8 Tom Horsley 2008-05-19 13:42:04 EDT
Created attachment 305986 [details]
/etc/sysconfig/network

Here's the network file. I'm pretty sure it has all the info correct
since everything worked fine once I disabled NetworkManager and enabled
network.
Comment 9 Dan Williams 2008-05-19 14:46:59 EDT
Thanks; that's what I need.  Will be fixed in an update for F9; already fixed in
rawhide with svn3675 and later.
Comment 10 Dan Williams 2008-05-19 15:38:05 EDT
When they finish, can you try:

http://koji.fedoraproject.org/koji/taskinfo?taskID=618281

thanks!
Comment 11 Dan Williams 2008-05-19 15:38:46 EDT
Of course you'll want to:

/sbin/chkconfig NetworkManager on
/sbin/chkconfig network off
service NetworkManager start

after installing the new packages.
Comment 12 Tom Horsley 2008-05-19 18:02:34 EDT
Hey, it worked! I installed the x86_64 packages from comment #10 above,
disabled network, enabled NetworkManager, and rebooted, and my network
was functional. Didn't have to add the gateway by hand.

Of course, now I've added bug 447442 :-).
Comment 13 Dan Williams 2008-05-19 18:53:17 EDT
Awesome, closing this one then.  Thanks!
Comment 14 Fedora Update System 2008-05-22 12:12:09 EDT
NetworkManager-0.7.0-0.9.3.svn3675.fc9 has been submitted as an update for Fedora 9

Note You need to log in before you can comment on or make changes to this bug.