Bug 446542 - No self contained minimal download to do a minimal install
No self contained minimal download to do a minimal install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 19:52 EDT by Tethys
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 00:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2008-05-14 19:52:23 EDT
Description of problem:
I want to install a minimal F9. That is, one with none of the optional
packages selected. None of the available install methods seem appropriate.

The install guide lists the following options:

1. Full distribution DVD
Nope. I don't want to download 6 CDs (or a whole DVD) worth just to install
a minimal system.

2. Live image
``also provides an "Install to Hard Disk" desktop shortcut''. Nope. That
implies it'll install a duplicate of the currently running system onto
the hard drive. Since I don't want X, the existence of a desktop shortcut
tends to rule that one out.

3. Minimal boot media
Sounds promising. Except that it doesn't do a minimal install. It refers
to the fact that the size of the media is minimal, rather than the
installed package list being minimal, which is what I want. Plus, it
necessitates a network install, which is not what I want.

All I want is a self containted single bootable image that I can use
to install a minimal Fedora 9 system. Once it's up and running, I can
yum install anything extra I need that's missing.

Now maybe you'll claim that a custom spin could be created to do this.
I'm sure it probably could. But that's simply not something I have the
time or facilities to do. I just want to install the OS. While I accept
that it's far from a mainstream approach, I suspect it's not sufficiently
unusual to justify its absence from the standard install methods.
Comment 1 Bill Nottingham 2008-05-15 00:19:42 EDT
A truly minimal install theoretically could be done with just CD1 (but I haven't
tried this recently.)

Realistically, this is the perfect area for a new user-contributed spin - it's
not one we're planning on doing as part of the main spin. Considering most users
of a 'minimal' install will want to do *some* minor package customization later,
(requiring network access in most cases), it seems best to target boot.iso +
HTTP/FTP for those that want a truly minimal download.

Note You need to log in before you can comment on or make changes to this bug.