Bug 446544 - Xorg unusable on Matrox MGA 400
Xorg unusable on Matrox MGA 400
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 20:05 EDT by Wolfgang Rupprecht
Modified: 2009-05-05 17:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 17:48:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (40.14 KB, text/plain)
2008-05-14 20:05 EDT, Wolfgang Rupprecht
no flags Details

  None (edit)
Description Wolfgang Rupprecht 2008-05-14 20:05:22 EDT
Description of problem:

My Matrox MGA 400 framebuffer has severe artifacts under F9.  It worked
perfectly under F8 just before the "upgrade".

Version-Release number of selected component (if applicable):

xorg-x11-drv-mga.i386                    1.4.8-1.fc9 

How reproducible:
100%

Steps to Reproduce:
1. boot
2. notice the mangled screen.  The effect is a bit similar to 
   a TV with screwed up interlace.  Alternate lines are over by approx.
   an inch (at ~100dpi)
  
Actual results:
mangled screen output

Expected results:
clean screen output

Additional info:
strangely the ascii terminals on alt-ctl-Fn also have a bug (perhaps related?)
Every other letter is missing.  This is also a new bug since fedora-8.
Comment 1 Wolfgang Rupprecht 2008-05-14 20:05:22 EDT
Created attachment 305420 [details]
xorg log file
Comment 2 Wolfgang Rupprecht 2008-05-14 20:08:58 EDT
I forgot to mention, the garbled graphics also exists in the fedora-9 installer.
 It is possible to install anyway, which I did, hoping it was just an installer
problem.
Comment 3 Wolfgang Rupprecht 2009-05-05 14:24:36 EDT
this has been fixed for a while in the current fedora.  Feel free to close.
Comment 4 Matěj Cepl 2009-05-05 17:48:18 EDT
Closing per comment 3

Note You need to log in before you can comment on or make changes to this bug.