This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 446550 - Not enough space in /boot/upgrade to cache stage2.img
Not enough space in /boot/upgrade to cache stage2.img
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 21:44 EDT by Peter Ennis
Modified: 2008-05-23 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 12:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Ennis 2008-05-14 21:44:52 EDT
Description of problem:

[Philip@f8 boot]$ sudo preupgrade
Loading "priorities" plugin
No package matched to remove
Not enough space in /boot/upgrade to cache stage2.img.

It will be downloaded once the installer starts.
DEBUG /sbin/grubby --title="Upgrade to Fedora 9 (Sulphur)"
--add-kernel=/boot/upgrade/vmlinuz --initrd=/boot/upgrade/initrd.img
--args="preupgrade lang=en_US.UTF-8 keymap=us 
method=http://fedora.mirrors.tds.net/pub/fedora/releases/9/Fedora/i386/os"
Probing devices to guess BIOS drives. This may take a long time.
[Philip@f8 boot]$ 


Version-Release number of selected component (if applicable):


How reproducible:

Try to upgrade from F8 to F9


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

No warning provided until after the fact.
If I try the upgrade it expects knowledge
of NFS/URL/DVD/VD/Disk image locations.

I have none of this info because I am
expecting preupgrade to have it.

Removed old kernel images etc. but still
not enough space.

Looks like I have to play with some partition
manager (but I am using a vol group)

How much space is needed?
Could the image not be loaded to some
other location? There is enough space
on the other partitions.



Additional info:
Comment 1 Peter Ennis 2008-05-23 12:08:56 EDT
No response on this.
FYI here is the setup of boot partition:

[Philip@f8 upgrade]$ pwd
/boot/upgrade
[Philip@f8 upgrade]$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       12G  6.1G  4.8G  57% /
/dev/sda1              99M   30M   64M  32% /boot
tmpfs                 189M   12K  189M   1% /dev/shm
[Philip@f8 upgrade]$ 

Comment 2 Peter Ennis 2008-05-23 12:17:07 EDT
I have run this a few times and noticed that it
messes up the grub.conf file.
Multiple references to
"title Upgrade to Fedora 9 (Sulphur)" e.g.:

[Philip@f8 grub]$ sudo cat grub.conf
Password:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24.7-92.fc8)
        root (hd0,0)
        kernel /vmlinuz-2.6.24.7-92.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.24.7-92.fc8.img
title Upgrade to Fedora 9 (Sulphur)
        kernel /upgrade/vmlinuz preupgrade lang=en_US.UTF-8 keymap=us
method=http://fedora.mirrors.tds.net/pub/fedora/releases/9/Fedora/i386/os
        initrd /upgrade/initrd.img
title Upgrade to Fedora 9 (Sulphur)
        kernel /upgrade/vmlinuz preupgrade lang=en_US.UTF-8 keymap=us
method=http://fedora.mirrors.tds.net/pub/fedora/releases/9/Fedora/i386/os
        initrd /upgrade/initrd.img
title Upgrade to Fedora 9 (Sulphur)
        kernel /upgrade/vmlinuz preupgrade lang=en_US.UTF-8 keymap=us
method=http://fedora.mirrors.tds.net/pub/fedora/releases/9/Fedora/i386/os
        initrd /upgrade/initrd.img
title Fedora (2.6.24.5-85.fc8)
        root (hd0,0)
        kernel /vmlinuz-2.6.24.5-85.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.24.5-85.fc8.img
[Philip@f8 grub]$ 

Comment 3 Will Woods 2008-05-23 12:38:55 EDT
It needs ~120MB for installer images.

No, it can't be put on another partition - it needs to be on a partition that
GRUB / anaconda stage1 can read. Which means no LVM, among other things.

Yes, we know it adds new junk to grub.conf every time it runs. Normally you only
run it once, and it gets cleaned out when you finish your upgrade.

You shouldn't need URL/NFS image location info - that's what 'method=XXX'
specifies. Not sure why anaconda would ask you that.

You will need to configure a wired network interface after rebooting to download
stage2.img and complete the upgrade. If you can't do that, and you can't create
a bigger /boot partition, you probably won't be able to run preupgrade at this time.

The next version of preupgrade makes that much clearer (and checks for disk
space on /boot before downloading all the packages). 

Note You need to log in before you can comment on or make changes to this bug.