Bug 446564 - Firstboot does not honour keyboard settings
Firstboot does not honour keyboard settings
Status: CLOSED DUPLICATE of bug 446345
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 23:42 EDT by Yaakov Nemoy
Modified: 2008-05-15 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 10:55:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Nemoy 2008-05-14 23:42:54 EDT
Description of problem: Normally, Fedora uses the keyboard settings from the
installer pervasively.  Firstboot does not honour the settings for alternate
(dvorak) keyboards.


Version-Release number of selected component (if applicable):
1.97-1.fc9


How reproducible:
Not yet tested.

Steps to Reproduce:
1. Start installing Fedora 9
2. Pick the netherlands locale (nl_NL.UTF-8) - This is only for accuracy, and
reflects what I picked at install time.
3. Pick a dvorak keyboard layout.
4. Continue with the install in the ordinary fashion
5. Observe incorrect (qwerty) keyboard set in firstboot.
  
Actual results:

Already duly noted.

Expected results:

Usage of the dvorak keyboard in the firstboot system.


Additional info:
Comment 1 Mathieu Bridon 2008-05-15 06:03:18 EDT
I had the same problem with the French latin 9 keyboard.

Someone on planet.fedoraproject.org reported it with a belgian keyboard.

So it looks like it's not related to the keyboard mapping you chose.

For me, the only page on firstboot where I noticed it was in the "create user"
page. Quite a problem for setting the password... :S
Comment 2 James 2008-05-15 07:03:21 EDT
Same with UK layout. Selected at install and first boot, but reverts to USA for
users. system-config-keyboard still reports UK layout, but this isn't
percolating through the system...
Comment 3 Fred New 2008-05-15 09:59:57 EDT
The same with installing in English and an Estonian keyboard.  The first
evidence of a problem was at the "create user" page.  The characters produced
weren't Latin.  I'm not worldly enough to say what they were.  I had to skip
creating a new user and also setting an NTP server.  The xorg.conf file matched
what I had from F9 preview release and Gnome worked correctly.
Comment 4 Chris Lumens 2008-05-15 10:55:06 EDT

*** This bug has been marked as a duplicate of 446345 ***

Note You need to log in before you can comment on or make changes to this bug.