Bug 446584 - Crash: Black Screen after Firstboot (after send smolt profile)
Crash: Black Screen after Firstboot (after send smolt profile)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 04:27 EDT by Silvio Schneider
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages with 2 boot secquences. first one crashes (129.90 KB, text/plain)
2008-05-17 06:01 EDT, Silvio Schneider
no flags Details

  None (edit)
Description Silvio Schneider 2008-05-15 04:27:36 EDT
Description of problem:
Crash: Black Screen after Firstboot (after pressing button next, send smolt
profile). Switching to console with Alt-CTRL-F1 is not possible.

Version-Release number of selected component (if applicable):
Fedora 9 Sulphur Final

How reproducible:
It's reproducible with my PC every time. After a reboot, via reboot button,
firstboot shows up again, but same problem. See additional info.

Steps to Reproduce:
1. install fedora 9 (no special settings)
2. reboot
3. click trough firstboot, till blackscreen
  
Actual results:
Crash: Black Screen after Firstboot (after send smolt profile)
Switching to console with Alt-CTRL-F1 is not possible.

Expected results:
Gnome Login

Additional info:
The PC is brand new, bought 1.Mai 2008. In short: Asus Mainboard, QuadCore
Intel, 4G RAM, NVIDIA 8600 graphiccard.
I was running Fedora 8 for 1 week on this machine. I will check my smolt summary
on firstboot, to find the UUID and post it here. The Smolt Profile should be on
the smolt internet server, because i did a transmission with fedora 8.
Comment 1 Silvio Schneider 2008-05-15 12:56:45 EDT
I looked up my uuid in the bootloader grub
(0bd041ca-8e38-4de3-9fb9-40877250ceb0), unfortunatly my profile has never been
trasmitted to smolt.fedoraproject.org. So there is no hardware-profile on the
internet.

If I now run fedora9 it startsup, it starts udev, switches to the graphical
mode. Starts a lot of services and then crashes just before it should show the
gnome login screen.

Is there anything I can do with the interactive startup or with passings
arguments to the kernel?
Comment 2 Chris Lumens 2008-05-15 13:06:57 EDT
Start up in runlevel 1 and chkconfig firstboot off.  Then it'll be disabled and
you can reboot as normal.  While you're at it, you can also see if there are any
/tmp/firstboot* files that you can attach to this bug report.
Comment 3 Silvio Schneider 2008-05-15 13:44:03 EDT
hi clumens. How can i startup in runlevel 1 ?
I have no shell, not any other access to /etc/inittab or something.
Comment 4 Chris Lumens 2008-05-15 14:35:44 EDT
This is old, but still relevant:

http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/custom-guide/s1-rescuemode-booting-single.html

Just follow the five steps at the beginning, and instead of "single", use "1". 
This will only affect the one bootup, not the next time you boot.
Comment 5 Silvio Schneider 2008-05-15 18:07:52 EDT
I have mounted the harddisk using knoppix, but nothing like expected. I just can
see this: 
knoppix@Knoppix:/media/sda1$ ls -la
insgesamt 6271
drwxr-xr-x  5 root root    1024 15. Mai 00:29 .
drwxr-xr-x 10 root root       0 15. Mai 23:53 ..
-rw-r--r--  1 root root   86348  1. Mai 12:34 config-2.6.25-14.fc9.i686
drwxr-xr-x  3 root root    1024 15. Mai 00:25 efi
drwxr-xr-x  2 root root    1024 15. Mai 00:36 grub
-rw-------  1 root root 3298370 15. Mai 00:29 initrd-2.6.25-14.fc9.i686.img
drwx------  2 root root   12288 15. Mai 00:19 lost+found
-rw-r--r--  1 root root  892575  1. Mai 12:34 System.map-2.6.25-14.fc9.i686
-rwxr-xr-x  1 root root 2088288  1. Mai 12:34 vmlinuz-2.6.25-14.fc9.i686
I am going to try your workaround now. However knoppix V.5.3.1 runs fine as well.
Comment 6 Silvio Schneider 2008-05-15 18:28:57 EDT
Guess what, this is my first comment with fedora 9. Gnome 2.22.1 is up and
running. Start up in runlevel 1 and >chkconfig firstboot off
works. Of course, this workaround isn't nice at all, but works at last.
Unfortunatly there is no logfile under the /tmp dir
[root@tower2 tmp]# ls
gconfd-gdm   gconfd-suvi     orbit-gdm   pulse-gdm   ssh-pxOUAL2873
gconfd-root  keyring-yRMhW6  orbit-suvi  pulse-suvi  virtual-suvi.c69qKr

hu fedora9 rocks at last. An for the human part. Its 00:28 I need some sleep.
Comment 7 Silvio Schneider 2008-05-16 09:27:13 EDT
>chkconfig firstboot off
does this turn firstboot off permanently or just once?
Comment 8 Chris Lumens 2008-05-16 10:55:36 EDT
Permanently.  Luckily you can still run all the tools that firstboot offers from
various places under the System->Administration menu in GNOME.

The workaround isn't supposed to be nice, just make things work.  That's why
it's a workaround.
Comment 9 Silvio Schneider 2008-05-17 05:43:58 EDT
housten, we still have a problem. As I understood firstboot is off.
Unfortunalty, if I now startup my PC I still get a blackscreen just before the
gnome login screen.
But If I start startup in runlevel 1 and then switch to "init 5".
As far as I know Fedora 9 is using UPstart, wich starts things in parallel. I
don't know if Init for System V is still there, wich might solve the problem.
So far the source that causes the blackscreen crash is still unknown. What could
be the next steps?
Comment 10 Silvio Schneider 2008-05-17 06:01:38 EDT
Created attachment 305795 [details]
/var/log/messages with 2 boot secquences. first one crashes

/var/log/messages with 2 boot secquences. first one crashes
Starting Mai 17:14:55  crashes 11:15:01, without user interaction.

Second one is booting in runlevel 2 then login in as root, switching to init 5
Gnome Login screen shows up as expected.
Comment 11 Silvio Schneider 2008-05-17 06:07:02 EDT
Smolt profile is on the net. Can be seen under:
http://www.smolts.org/show?uuid=pub_9fb358b0-5fca-4c62-867c-3805aa95394e
Comment 12 FR 2008-05-17 21:06:46 EDT
I have a similar problem after completing the installation, created user,... 
sent the HW profile, when I press the "Finish" button the system freezes with a 
blank screen. I have a Q5500 2.40, Nvidia 8800 GTX. Using the rescue option of 
the installation DVD, I was able to access the /mnt/sysimage/etc/X11/xorg.conf 
replace the driver "nv" with a random value. After rebooting X fails and I can 
access the console. At that point if I set the driver back to "nv" in xorg.conf 
and start X with startx -ignoreABI I can access KDE. My scenario could be 
completely unrelated to the original post but at least the symptoms look the 
same. In my case the problem seems related to X. BTW the xorg.conf looks 
extremely simple, I tried X -configure, the new xorg.conf looked a little more 
complete but with the same results.
Comment 13 FR 2008-05-31 21:46:43 EDT
With the latest nvidia driver 
(http://www.nvidia.com/object/linux_display_amd64_173.14.05.html), the problem 
seems to have been sovled.
Comment 14 Bug Zapper 2009-06-09 20:50:31 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-07-14 14:01:21 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.