Bug 446609 - gnome-display-properties/can't enabe dual head connectivity
gnome-display-properties/can't enabe dual head connectivity
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 07:11 EDT by Amitakhya Phukan
Modified: 2010-03-18 13:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-18 13:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detecting monitors (23.33 KB, image/png)
2008-05-15 07:12 EDT, Amitakhya Phukan
no flags Details
monitor settings (22.85 KB, image/png)
2008-05-15 07:13 EDT, Amitakhya Phukan
no flags Details
log file of Xorg (53.41 KB, text/plain)
2008-05-15 12:27 EDT, Amitakhya Phukan
no flags Details
xorg log file (50.39 KB, text/plain)
2008-05-25 16:14 EDT, Andreas Tunek
no flags Details

  None (edit)
Description Amitakhya Phukan 2008-05-15 07:11:53 EDT
Description of problem:
I connected my desktop monitor to my laptop for dual display, however it doesn't
work properly. I ran gnome-display-properties and I clicked on detect displays.
After that I entered the screen resolution and the refresh rates for both the
monitors but I couldn't get the proper displays. It sometimes comoes up with
proper displays and sometimes it doesn't. Would like to see more consistence in
this application.


Version-Release number of selected component (if applicable):
[root@aphukan ~]# rpm -qf `which gnome-display-properties `
control-center-2.22.1-4.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Dual Head display doesn't work.

Expected results:
Dual head display should work.

Additional info:
I also did try to change the xorg.conf through system-config-display but I
couldn't save the changes. It seems only "Cancel" button works there. :)
Comment 1 Amitakhya Phukan 2008-05-15 07:12:38 EDT
Created attachment 305467 [details]
detecting monitors
Comment 2 Amitakhya Phukan 2008-05-15 07:13:05 EDT
Created attachment 305468 [details]
monitor settings
Comment 3 Amitakhya Phukan 2008-05-15 07:13:43 EDT
Please do get back to me if you need any other information from me.
Comment 4 Bastien Nocera 2008-05-15 08:55:47 EDT
Attach your X.org log file, as well as the output of "xrandr -q" on the
command-line, when reproducing the problem.
Comment 5 Amitakhya Phukan 2008-05-15 12:27:22 EDT
xrandr -q output :
-------------------

[aphukan@aphukan ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1050, maximum 1920 x 1200
VGA-0 connected 1400x1050+0+0 (normal left inverted right x axis y axis) 376mm x
301mm
   1280x1024      60.0 +   75.0     60.0     60.0  
   1920x1080      59.9  
   1680x1050      59.9  
   1600x1024      60.2  
   1400x1050      60.0* 
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       75.0     75.0     75.0     70.0     60.0  
   1024x768       75.1     75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     75.0     60.0     59.9  
   720x400        70.1  
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050      60.0*+
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
S-video disconnected (normal left inverted right x axis y axis)
[aphukan@aphukan ~]$
Comment 6 Amitakhya Phukan 2008-05-15 12:27:52 EDT
Created attachment 305507 [details]
log file of Xorg
Comment 7 Amitakhya Phukan 2008-05-15 12:31:16 EDT
also, i can't use "individual desktop" properties. every time i reboot, the
second monitor resolution settings are not properly stored. seems xorg is
overwriting whatever gnome-display-properties sets. whenever i login after a
reboot, the monitor shows "Cannot display this video mode ... Optimum resolution
1280X1024 60 Hz". i tried entering this information in system-config-display but
it doesn't save. nothing happens when i click ok. previous fedora versions it
used to write a message saying the old xorg.conf settings are overwritten, but
nothing such happens now.
Comment 8 Andreas Tunek 2008-05-25 16:13:46 EDT
I can't get get my VGA output to work either. Here is some output.

xrandr -q
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 230mm
   1024x768       61.3*+   60.0  
   800x600        60.3  
   640x480        59.9  
S-video disconnected (normal left inverted right x axis y axis)


[tuna@localhost ~]$ cat /etc/X11/xorg.conf 
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "se"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection


Comment 9 Andreas Tunek 2008-05-25 16:14:49 EDT
Created attachment 306629 [details]
xorg log file
Comment 10 Bug Zapper 2009-06-09 20:51:08 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Amitakhya Phukan 2009-06-15 04:44:16 EDT
Confirmed it still happens in Fedora 11.
Comment 12 Amitakhya Phukan 2009-06-15 04:45:09 EDT
Changing the version to 11 for Fedora.
Comment 13 Matěj Cepl 2009-11-05 13:19:37 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 14 Amitakhya Phukan 2009-11-20 01:53:34 EST
Hi,

I installed a fresh Fedora 12 with external monitor connected. The anaconda installation was all fuzzy. Post install, the dual display was working properly and I could select different "positions" for the laptop and monitors. They worked perfectly. Then I disconnected the external monitor, rebooted the laptop. After logging in, I reconnected the external monitor and I went to System -> Preferences -> Display. As soon as I clicked on it, the monitor came alive with the old settings that I had.

Hence, it seems the problem is not existing with Fedora 12.

One question though : Why should I have to click on the Display menu for the monitor to come alive ? Should it not come alive as soon as I connect it to the laptop ?

Otherwise, it seems to be fine with the present Fedora 12.

Thanks a lot for your help.
Comment 15 Matěj Cepl 2010-03-18 13:38:48 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.