Bug 446623 - gnome-display-properties won't show two screens side by side
gnome-display-properties won't show two screens side by side
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 09:01 EDT by Janne Pihlajaniemi
Modified: 2008-05-16 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 04:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.log (39.84 KB, text/plain)
2008-05-16 03:55 EDT, Janne Pihlajaniemi
no flags Details

  None (edit)
Description Janne Pihlajaniemi 2008-05-15 09:01:24 EDT
Description of problem:

When setting my two screens (laptop & external lcd) side by side in
gnome-display-properties, both screens still show the same content. I'd expect
the desktop to span over the two displays.

Version-Release number of selected component (if applicable):

control-center-2.22.1-4.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

My machine has an Intel 945 graphics controller.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
Comment 1 Bastien Nocera 2008-05-15 09:10:46 EDT
Is "mirror screens" enabled? Please attach your X.org log as well as the output
of "xrandr -q" when reproducing the problem.
Comment 2 Janne Pihlajaniemi 2008-05-16 03:54:28 EDT
Hi,

nope, the mirroring is not enabled. :)

[jannepih@localhost ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1024, maximum 1920 x 1920
VGA connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0     60.0     60.0*
   1920x1080      59.9
   1680x1050      59.9
   1600x1024      60.2
   1400x1050      60.0
   1440x900       59.9
   1280x960       60.0
   1360x768       59.8     60.0
   1152x864       75.0     75.0     75.0     70.0     60.0
   1024x768       75.1     75.0     70.1     60.0
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        75.0     72.8     75.0     60.0     59.9
   720x400        70.1
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
   1024x768       50.0 +   60.0*    40.0
   800x600        60.3
   640x480        60.0     59.9
[jannepih@localhost ~]$

Please find the Xorg.0.log attached.


Comment 3 Janne Pihlajaniemi 2008-05-16 03:55:06 EDT
Created attachment 305652 [details]
xorg.log
Comment 4 Janne Pihlajaniemi 2008-05-16 04:10:15 EDT
Actually, the spannig seems to work, just that the resolution of my displays
exceed 1920x1920. Is this the maximum resolution of my graphics card or is the
limitation somewhere else?

[jannepih@localhost ~]$ xrandr --output VGA --right-of LVDS
xrandr: screen cannot be larger than 1920x1920 (desired size 2304x1024)
[jannepih@localhost ~]$

When lowering the resolution, everything seems to work fine.
Comment 5 Bastien Nocera 2008-05-16 06:50:05 EDT
You can add a line in your xorg.conf. See the "Virtual" line in the examples:
http://intellinuxgraphics.org/dualhead.html

2048x2048 seems to be the maximum resolutions you can get with the intel drivers
though. YMMV.
Comment 6 Ray Strode [halfline] 2008-05-16 10:09:31 EDT
This is a known limitation of X right now.  The X team is working to have a
better story by F10.

Note You need to log in before you can comment on or make changes to this bug.