Bug 446630 - SELinux is preventing ifconfig (ifconfig_t) "read" to /var/lib/dhclient/dhclient-eth1.leases (dhcpc_state_t)
SELinux is preventing ifconfig (ifconfig_t) "read" to /var/lib/dhclient/dhcli...
Status: CLOSED DUPLICATE of bug 446632
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 10:03 EDT by David Hislop
Modified: 2008-05-16 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 15:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hislop 2008-05-15 10:03:11 EDT
Description of problem:
Newly installed Fedora 9; configured wired and wireless adaptors to be managed
by Network Manager, restarted network service; received SELinux error.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Every time

Steps to Reproduce:
1. As above
2.
3.
  
Actual results:

===== Copy from setroubleshoot starts
Summary:

SELinux is preventing ifconfig (ifconfig_t) "read" to
/var/lib/dhclient/dhclient-eth1.leases (dhcpc_state_t).

Detailed Description:

SELinux denied access requested by ifconfig. It is not expected that this access
is required by ifconfig and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for /var/lib/dhclient/dhclient-eth1.leases,

restorecon -v '/var/lib/dhclient/dhclient-eth1.leases'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:system_r:ifconfig_t:s0
Target Context                unconfined_u:object_r:dhcpc_state_t:s0
Target Objects                /var/lib/dhclient/dhclient-eth1.leases [ file ]
Source                        ifconfig
Source Path                   /sbin/ifconfig
Port                          <Unknown>
Host                          slate
Source RPM Packages           net-tools-1.60-87.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-42.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     slate
Platform                      Linux slate 2.6.25-14.fc9.i686 #1 SMP Thu May 1
                              06:28:41 EDT 2008 i686 i686
Alert Count                   5
First Seen                    Thu 15 May 2008 07:39:47 PM EST
Last Seen                     Thu 15 May 2008 11:46:56 PM EST
Local ID                      64891fc8-4be5-4fb8-92d3-b587593792a8
Line Numbers                  

Raw Audit Messages            

host=slate type=AVC msg=audit(1210859216.304:77): avc:  denied  { read } for 
pid=1664 comm="ifconfig" path="/var/lib/dhclient/dhclient-eth1.leases" dev=dm-0
ino=86859 scontext=unconfined_u:system_r:ifconfig_t:s0
tcontext=unconfined_u:object_r:dhcpc_state_t:s0 tclass=file

host=slate type=SYSCALL msg=audit(1210859216.304:77): arch=40000003 syscall=11
success=yes exit=0 a0=8206d48 a1=8206b68 a2=81ecd58 a3=0 items=0 ppid=1637
pid=1664 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) ses=1 comm="ifconfig" exe="/sbin/ifconfig"
subj=unconfined_u:system_r:ifconfig_t:s0 key=(null)
===== Copy from setroubleshoot ends



Expected results:
No errors.

Additional info:
Comment 1 Daniel Walsh 2008-05-16 15:56:59 EDT

*** This bug has been marked as a duplicate of 446632 ***

Note You need to log in before you can comment on or make changes to this bug.