Bug 446640 - base URL incorrectly set
base URL incorrectly set
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 10:25 EDT by David Woodhouse
Modified: 2008-05-23 03:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 03:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-05-15 10:25:16 EDT
The button on http://www.freshwell-health-centre.com/ doesn't seem to work,
although I'm sure it once did.

Admittedly, it's one of the most gratuitous uses of flash I've ever encountered,
but still it ought to work.

I see the following output:

Starting process: /usr/bin/gtk-gnash -x 58722964 -j 100 -k 23 -u
http://www.freshwell-health-centre.com/button7.swf -F 53 -U
http://www.freshwell-health-centre.com/ -P base=. -P height=23 -P
pluginspage=http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash
-P quality=high -P src=button7.swf -P type=application/x-shockwave-flash -P
width=100 - 
RcInitFile: parsing /home/dwmw2/.gnashrc
17304] 15:22:49: DEBUG: gnash::media::sound_handler*
gnash::media::create_sound_handler_gst() enter
17304] 15:22:50: DEBUG: returning
17304] 15:22:50: DEBUG: Checking support for MIT-SHM...
17304] 15:22:50: DEBUG: NOTICE: MIT-SHM available (version 1.1)!
17304] 15:22:50: DEBUG: Your X server expects RGB24 pixmap data for standard mode.
17304] 15:22:50: DEBUG: Created XEmbedded window
17304] 15:22:50: DEBUG: X server pixel format is (R16:8, G8:8, B0:8, 32 bpp)
17304] 15:22:50: DEBUG: X server is using ARGB32 pixel format
17304] 15:22:50: DEBUG: framebuffer pixel format is ARGB32 (big-endian host)
17304] 15:22:50: DEBUG: Base url set to: file:///home/dwmw2/.
17304] 15:22:50: DEBUG: GTK-AGG: Using shared memory image
17304] 15:22:50: DEBUG: initialized AGG buffer <0xf797c000>, 9200 bytes, 100x23,
rowsize is 400 bytes
17304] 15:22:50: UNIMPLEMENTED:   FIXME: tagtype = 55
17304] 15:22:50: MALFORMED SWF: last expected SHOWFRAME in SWF stream
'http://www.freshwell-health-centre.com/button7.swf' isn't followed by an END (41).
17304] 15:22:50: ERROR: Parsing exception: premature end of tag: need to read 26
bytes, but only 23 left in this tag
17304] 15:22:50: DEBUG: Global instance list grew to 8 entries
17304] 15:22:51: DEBUG: get url: target=_parent, url=file:///home/dwmw2/Homepage
Frameset.htm (Homepage Frameset.htm), method=0 (sendVars:0, loadTarget:0,
loadVariable:0)
17304] 15:22:51: SECURITY: Load of file /home/dwmw2/Homepage Frameset.htm
forbidden (starting url http://www.freshwell-health-centre.com/button7.swf is
not a local resource).
Comment 1 Patrice Dumas 2008-05-15 11:44:12 EDT
I can reproduce the bug. I'll wait a bit for the next release which is 
due in few days, and if I can still reproduce it I'll fill it 
upstream.
Comment 2 David Woodhouse 2008-05-15 12:53:04 EDT
It still happens with gnash from cvs. Looks like it sees the
<param name="base" value="."> in the HTML source, and calculates that relative
to the current directory, instead of to the original URL.
Comment 3 Patrice Dumas 2008-05-18 06:59:30 EDT
A fix should in upstream CVS. Could you please test?

Bug report I filled upstream is:
http://savannah.gnu.org/bugs/?23260
Comment 4 David Woodhouse 2008-05-18 11:11:12 EDT
'cvs up -dP ; make' fails, as usual. Normally this is because Gnash is afflicted
by autotools and doesn't just use proper makefiles; I'll try to make it work...
Comment 5 David Woodhouse 2008-05-18 11:18:44 EDT
Life's too short to work out why autotools were causing problems (I think
libnet/Makefile wasn't including rtmp_msg.cpp even after I'd rerun ./autogen.sh
and ./configure and it had tested my fortran compiler a dozen more times, as it
does).

Building from a clean checkout works, and the bug is fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.