This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446643 - ktorrent: systray icon not showing in Gnome panel
ktorrent: systray icon not showing in Gnome panel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ktorrent (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 10:27 EDT by Christopher Stone
Modified: 2013-06-12 17:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 05:18:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2008-05-15 10:27:57 EDT
ktorrent icons do not show up in the application when you run it under Gnome. 
In addition, the panel icon does not show up properly in the gnome panel.
Comment 1 Rex Dieter 2008-05-15 10:42:53 EDT
Oh, I thought you had been talking about menu icon when discussing this on irc.

Screenshot?  (would help).

Otherwise, can't imagine this being ktorrent's fault.
Comment 2 Rex Dieter 2008-05-15 10:57:34 EDT
Can't reproduce.

1.  Applications->Internet->ktorrent
2.  ktorrent systray icon appears
Comment 3 Roland Wolters 2008-05-15 11:13:08 EDT
I can't verify this here.

Please check the following things:
- Which version of ktorrent are you using? (Help, info)
- Do you actually see the ktorrent symbol in the Gnome menu?
- Does the problem also come up if you create a new user and launch ktorrent 
there?
- Is there any error output when you run ktorrent from within a terminal?
Comment 4 Christopher Stone 2008-05-15 11:15:33 EDT
okay, I moved my ~/.kde dir to ~/.kde.bak and this fixes the problem.  I must
have set some alternate icon set in KDE which caused this.  Using the default
icon set fixes the problem for me.
Comment 5 Roland Wolters 2008-05-16 05:18:23 EDT
Ok, I mark this bug as fixed since it looks like it is not a ktorrent bug at 
all, but rather an icon set problem or a KDE problem in general.

Please reopen the bug against the right KDE component. Try to narrow it down 
prior to filling the new bug to make sure what exactly causes the bug. For 
example you could
- change the icon set to check if that is the problem
- copy back the parts of ~/.kde.bak application for application and check when 
the bug hits in

Also, the description of the bug is still not clear - you haven't answer the 
question if the icon is missing in the system tray alone or in the Gnome menu 
as well.

If it turns out the bug indeed depends on ktorrent, please reopen this bug 
report.
Comment 6 leebraid 2013-06-12 17:12:56 EDT
On Linux Mint / Cinnamon, I fixed this issue using:

rm ~/.kde/cache-$(hostname)/icon-cache.kcache

Note You need to log in before you can comment on or make changes to this bug.