Bug 446660 - evdev no longer recognizes mouse thumb button (mx revolution)
evdev no longer recognizes mouse thumb button (mx revolution)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 11:31 EDT by Christopher Stone
Modified: 2008-07-20 22:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-20 22:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My config file (1.78 KB, text/plain)
2008-05-17 11:22 EDT, Christopher Stone
no flags Details
log file (44.94 KB, text/plain)
2008-05-17 11:24 EDT, Christopher Stone
no flags Details
Honor button presses from mice with a lot of buttons (2.64 KB, patch)
2008-06-12 03:49 EDT, Bob Richmond
no flags Details | Diff

  None (edit)
Description Christopher Stone 2008-05-15 11:31:06 EDT
In fedora 7 the evdev driver was able to see my mouses thumb button as button
17.  In fedora 8 evdev did not work at all.  Now in fedora 9, evdev is not
recognizing my mouses thumb button at all.  In Fedora 9, if I run xev and press
the thumb button, nothing will print at all.

I have a Logitech MX Revolution mouse.
Comment 1 Matěj Cepl 2008-05-16 17:23:25 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Christopher Stone 2008-05-17 11:22:17 EDT
Created attachment 305810 [details]
My config file

Here is my xorg.conf file, not I cannot seem to get emulate3buttons to work
either, but that is another story.
Comment 3 Christopher Stone 2008-05-17 11:24:04 EDT
Created attachment 305811 [details]
log file

And here is my log file, (the word "not" should be "note" in the comment
above).
Comment 4 Gérard Milmeister 2008-06-07 05:16:08 EDT
Confirmed, the three thumb buttons activated by the thumb wheel don't work.
Comment 5 Christopher Stone 2008-06-07 11:03:56 EDT
Okay, point of clarification.  This mouse has *a lot* of buttons.  If indeed the
thumb wheel has three buttons "wheel forward", "wheel backward", and "wheel
depress" (it feels like there may even be a fourth button, "wheel down"), then I
should add that the wheel forward and back buttons *never* worked in evdev.  In
F7 only the thumb wheel depress what recognized.
Comment 6 Bob Richmond 2008-06-12 03:49:00 EDT
Created attachment 309041 [details]
Honor button presses from mice with a lot of buttons
Comment 7 Bob Richmond 2008-06-12 03:49:22 EDT
I too have this mouse. I tracked this problem down to the button codes for
manipulating the thumb dingus not being translated to X button events by evdev
because the button codes (0x118, 0x11A, and 0x11C) don't have symbolic constants
in linux/input.h. F8 evdev just used basic math to convert valid button ranges
back into X button events, so I modified it to go back to that behaviour.

This patch fixes it for me.
Comment 8 Peter Hutterer 2008-07-20 22:33:39 EDT
Fixed in evdev 2.0.2, available in F9 and rawhide.

Note You need to log in before you can comment on or make changes to this bug.