Bug 446665 - Missing ISO 9660 image (image #1 missing)
Missing ISO 9660 image (image #1 missing)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 12:05 EDT by Bernhard Fastenrath
Modified: 2008-05-15 17:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 17:15:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Fastenrath 2008-05-15 12:05:20 EDT
Description of problem:

Anaconda fails to install in text mode with the following error:
Missing ISO 9660 image
The installer has tried to mount image #1, but cannot find it on the hard drive.
Please copy this image to the drive and click Retry.

Version-Release number of selected component (if applicable):

Anaconda 11.4.0.82

How reproducible:

Installation from local hard disk in text mode.
initrd.img, vmlinuz, boot.iso and Fedora-9-i386-netinst.iso dated 08/05/08 from
ftp://ftp.stw-bonn.de./pub/fedora/linux/releases/9/Fedora/i386/iso

Steps to Reproduce:
1. iso images on /dev/sda1
2. root partition on /dev/sda5
3. upgrade existing system OR install new system
4. error occurs after the GRUB installation

Actual results: error message (see above)
Expected results: network installation

Additional info:
The error shouldn't occur because the Fedora-9-i386-netinst.iso has been found
earlier and the containing partition is already mounted on /dev/isodir.
Fedora-9-i386-netinst.iso shouldn't require another image but proceed with a
network installation.

(By the way: The containing partition of the ISO image cannot be the destination
for a system upgrade or the installation aborts earlier than the above error
with the following error:
 "Mount failed: One or more of the file systems listed in the /etc/fstab on your
Linux system cannot be mounted."
 This problem doesn't seem to be mentioned in the
 Fedora 9 Installation Guide)

-- 
http://politics.wikia.com/index.php?title=Extending_human_legislation_to_artificial_intelligences
http://education.wikia.com/wiki/User:Fasten/Pilingual_Primer
http://en.wikibooks.org/wiki/Mentoring_Handbook
http://en.wikiversity.org/wiki/Topic:Assistant_teacher_program
Comment 1 Chris Lumens 2008-05-15 12:55:27 EDT
What's on your /dev/sda1 partition?  Just the netinst.iso, or the entire set of
ISO images from the FTP site you gave?
Comment 2 Bernhard Fastenrath 2008-05-15 15:49:27 EDT
I've tried both boot.iso and Fedora-9-i386-netinst.iso and with and without a
subdirectory. (as per "6.2. Installation from a Hard Drive"
http://docs.fedoraproject.org/install-guide/f9/en_US/sn-installing-from-harddrive.html)
Apparently stage2.img from netinst.iso is already mounted with /dev/loop0 on
/mnt/runtime.
Comment 3 Chris Lumens 2008-05-15 17:15:40 EDT
In order to use the HDISO installation method, you need more than just the
netinst.iso on your partition.  That's a ~ 100 MB ISO image that contains both
the boot stuff and anaconda's stage2 required to provide the graphical
environment.  It does not, however, contain any packages.  You either need grab
the DVD or CD images from your FTP site and put them on your hard drive
partition, or choose a different installation method.

Note You need to log in before you can comment on or make changes to this bug.