Bug 446667 - GUI helper does NOT work
GUI helper does NOT work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 12:17 EDT by John Raff
Modified: 2008-05-28 10:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 05:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"pkcon search name yum" (4.10 KB, text/plain)
2008-05-15 23:47 EDT, John Raff
no flags Details
Another pkgcon search name yum output (4.00 KB, text/plain)
2008-05-20 12:26 EDT, Penelope Fudd
no flags Details

  None (edit)
Description John Raff 2008-05-15 12:17:48 EDT
I installed Fedora 9 DeskTop on two different (P3 and P4 class) machines.
I attempted to use the Add/Remove Software GUI for "yum".
1) It's rather slow! Yeah I understand that it's getting all it's data from the
server.
2) At no time was I able to get it to work. The Install/Remove button changed
color but NOTHING else happened!!!

I use "yum" to install the SAMBA software that I wanted so the underlying
application still works as expected, but the GUI interface did NOT!!!!!!!
Comment 1 Richard Hughes 2008-05-15 16:12:27 EDT
The first time you run gpk-application, the data is downloaded from the server,
which is dependant on the speed of your connection, not the speed of your computer.

What does "pkcon search name yum" print?
Comment 2 John Raff 2008-05-15 23:47:36 EDT
Created attachment 305609 [details]
"pkcon search name yum"

"pkcon search name yum" output
Comment 3 John Raff 2008-05-15 23:49:52 EDT
I'm going to be away over the weekend but will pick up Mon. morning.
---
I have a standard ComCast Internet connection for Northern NJ about 3meg down
and 700Kb up.
---
Output of "pkcon search name yum" sent "attached"
11:50PM 5/15/08 EDST
Comment 4 Richard Hughes 2008-05-19 06:48:21 EDT
>search-name runtime was 27.2 seconds

Did the Add/Remove Software search take longer than this?
Comment 5 John Raff 2008-05-19 14:32:25 EDT
>> Add/Remove Software

NOTHING HAPPENED!!
No window, no update, no install, NOTHING!

Yes I waited for something to happen, several minutes, NOTHING!
Comment 6 Penelope Fudd 2008-05-20 12:24:23 EDT
Hi..

I've also got a problem with the packagekit gui; the install button doesn't do
anything.  This happens in two cases:

1) Automatic updates presented: There were 11 updates to install, but clicking
the install button didn't do anything; typing 'yum -y update' installed them,
however.

2) Selecting software to install: Selecting software works, but the install
button doesn't do anything, and there are no error messages or dialog boxes to
explain the situation.

Note: typing 'yum install pirut' is redirected to 'yum install
gnome-packagekit'.  That's evil.  Pirut works, but now I can't install it.
Comment 7 Penelope Fudd 2008-05-20 12:26:45 EDT
Created attachment 306149 [details]
Another pkgcon search name yum output

pkgcon search name yum > /tmp/pkcon.output
Comment 8 Robin Norwood 2008-05-20 12:45:59 EDT
Can you also give us the output of 'pkcon update <package>' or 'pkcon install
<package>' ?  The output of 'pkmon' running at the same time that you do the
updates might be helpful as well.

gnome-packagekit obsoletes pirut so that upgrades from F8-F9 work.  Jeremy (the
maintainer of pirut) didn't want to continue to maintain pirut for F9 if we're
replacing it with PackageKit.  No evil intended.
Comment 9 Penelope Fudd 2008-05-20 16:38:25 EDT
I found the cause of my problem; I was signed on as root.  Signing on as a
regular user brings up a root password dialog box.

Additionally, there was a dialog box that I had suppressed earlier that said:
  Failed to update system
  The error was: org.freedesktop.packagekit.update-system auth_admin_keep_always

This was probably what was supposed to pop up when I hit 'install', but it had
been suppressed.

Comment 10 John Raff 2008-05-20 18:19:00 EDT
Two issues;

1) Have the application check up front, first thing for the "root" id and warn
the user to login as some lower level entity.

2) All previous FC1 - F8 installs or updates ran fine under "root". Don't rock
the boat! Let root install and update!
Comment 11 Richard Hughes 2008-05-28 05:32:16 EDT
>Have the application check up front, first thing for the "root" id

Done and pushed to updates.

>All previous FC1 - F8 installs or updates ran fine under "root"

Sure, we're now in a PolicyKit world. GTK tools are really insecure when run as
root - see https://fedoraproject.org/wiki/PackageKitFaq for details.
Comment 12 John Raff 2008-05-28 10:31:50 EDT
As far as I'm concerned this bug is closed. I should have been some other user
to run "Add/Remove Software" and it worked fine when I tried it.
-------------
Now we are getting into semantics and woulda, coulda, shoulda issues.

"PolicyKit world" may be fine for day to day usage but when one is setting up
one's desired environment with all the installs and tweaking most of which must
be done via root, doing it through su or sudo is a royal pain!
And yes I understand the problems of root permissions.

Maybe Linux need to take an idea from Windows and have levels of authority, an
Admin that can do almost anything but be warned or prevented when doing
something really dangerous.
Windows uses "System" as the ultimate authority.

Note You need to log in before you can comment on or make changes to this bug.