Bug 44667 - Start Audio before USB -- else chaos reigns (initscripts / sndconfig)
Summary: Start Audio before USB -- else chaos reigns (initscripts / sndconfig)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 4.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-15 05:38 UTC by Bryce Nesbitt
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 19:48:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryce Nesbitt 2001-06-15 05:38:30 UTC
I know that USB is deliberately started early (presumably to allow USB
storage devices to work optimally).  But this behavior causes audio
problems.

If you have a standard sound card, and USB audio devices, you're in
trouble.  Unless you always leave your USB device either IN or OUT at
boot,  the "sound slot" entries in /etc/modules.conf get all confused and
step over each other.    Plus, the device entries for your sound cards are
constantly shifting order.

The solution is to start the normal bus-based sound cards first, since they
can't be removed or inserted.  Then start the removable devices.


			-Bryce

Note: With the emul10k1 sound card, if a USB audio device is inserted at
boot, you get no device entries assigned to the sound card.  Unplugging USB
brings back the emul10k1.  If you insert USB audio after boot, the USB
devices take the next available slots as you might expect (unless you do it
a bunch of times, in which case it all gets hoplessly mucked up).

Working usb audio devices include speakers & microphones.

Comment 1 Bryce Nesbitt 2001-06-15 05:39:58 UTC
Kudzu constantly whines about USB devices, no matter what you tell it.  This may
be related.

Get an Andrea NC-7100 USB Microphone if you want to test.


Comment 2 Bill Nottingham 2005-04-05 19:48:37 UTC
This is solved in FC3 - all built-in (PCI) devices are enumerated before USB.


Note You need to log in before you can comment on or make changes to this bug.