Bug 446678 - HP LaserJet 1020
HP LaserJet 1020
Status: CLOSED DUPLICATE of bug 505647
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
11
powerpc Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 12:40 EDT by Alexey Kuznetsov
Modified: 2013-03-05 22:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 11:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshoot (35.09 KB, text/plain)
2008-05-17 04:43 EDT, Alexey Kuznetsov
no flags Details
lshal (87.58 KB, text/plain)
2008-05-30 08:34 EDT, Alexey Kuznetsov
no flags Details
troubleshoot after setfacl (11.29 KB, text/plain)
2008-05-30 12:14 EDT, Alexey Kuznetsov
no flags Details
hp-info (8.87 KB, text/plain)
2008-06-04 15:27 EDT, Alexey Kuznetsov
no flags Details
hald.txt (73.48 KB, text/plain)
2008-06-06 14:51 EDT, Alexey Kuznetsov
no flags Details
hald-runner (35.04 KB, text/plain)
2008-06-06 14:54 EDT, Alexey Kuznetsov
no flags Details
hald-runner.txt (54.45 KB, text/plain)
2008-06-10 06:57 EDT, Alexey Kuznetsov
no flags Details
hald-runner.txt (35.13 KB, text/plain)
2008-06-10 08:18 EDT, Alexey Kuznetsov
no flags Details
hald-runner.message.log (4.86 KB, text/plain)
2008-06-10 08:20 EDT, Alexey Kuznetsov
no flags Details
usbmon log for ppc machine (bad) (9.19 KB, text/plain)
2009-03-07 16:21 EST, Alexey Kuznetsov
no flags Details
usbmon log for i386 (good) (9.50 KB, text/plain)
2009-03-07 16:22 EST, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2008-05-15 12:40:14 EDT
with hp-setup i have well configured and updated. I can see green status on
http://localhost:631/printers/HP_LaserJet_1020. But unable to print.


Unable to print on printer:

/var/log/messages

May 15 20:34:13 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 15 20:34:13 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 15 20:34:13 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 15 20:34:13 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 15 20:34:15 mini hpijs: io/hpmud/musb.c 135: unable get_string_descriptor
-1: Operation not permitted
May 15 20:34:15 mini hpijs: io/hpmud/musb.c 603: invalid product id string ret=-1
May 15 20:34:15 mini hpijs: io/hpmud/musb.c 1057: unable to open
hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 15 20:34:15 mini hpijs: unable to set device=HP LaserJet 1020, err=16
May 15 20:34:15 mini hpijs: unable to read client data err=-2
May 15 20:34:44 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 15 20:34:44 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 15 20:34:44 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 15 20:34:44 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
Comment 1 Tim Waugh 2008-05-16 03:19:28 EDT
Please select System->Administration->Printing from the Fedora menu, and then
Help->Troubleshoot from the menu bar in that configuration tool.  Follow the
instructions and then attach the troubleshoot.txt file you end up with.
Comment 2 Alexey Kuznetsov 2008-05-17 04:43:38 EDT
Created attachment 305791 [details]
troubleshoot
Comment 3 Tim Waugh 2008-05-29 09:55:37 EDT
Thanks.  What does 'hp-info' say?
Comment 4 Alexey Kuznetsov 2008-05-29 10:11:02 EDT
[axet@mini ~]$ hp-info 

HP Linux Imaging and Printing System (ver. 2.8.2)
Device Information Utility ver. 3.4

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/HP_LaserJet_1020?serial=JL2NBET

hp:/usb/HP_LaserJet_1020?serial=JL2NBET

error: Unable to communicate with device (code=12):
hp:/usb/HP_LaserJet_1020?serial=JL2NBET
error: Error opening device (Device not found). Exiting.




/var/log/messages
May 29 18:08:22 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 29 18:08:52 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 29 18:08:52 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 29 18:08:52 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 29 18:08:52 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 29 18:09:22 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 29 18:09:22 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 29 18:09:22 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 29 18:09:22 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...






at boot time my printer waked up, what mean successful firmware upload and he
well connected.
Comment 5 Tim Waugh 2008-05-29 10:34:02 EDT
What about 'hp-probe -busb'?
Comment 6 Alexey Kuznetsov 2008-05-29 10:43:45 EDT
[root@mini axet]# hp-probe -busb

HP Linux Imaging and Printing System (ver. 2.8.2)
Printer Discovery Utility ver. 4.0

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


--------------------
| DEVICE DISCOVERY |
--------------------

  Device URI                               Model           
  ---------------------------------------  ----------------
  hp:/usb/HP_LaserJet_1020?serial=JL2NBET  HP LaserJet 1020

Found 1 printer(s) on the 'usb' bus.

[root@mini axet]# 
Comment 7 Tim Waugh 2008-05-29 11:33:17 EDT
The 'lsusb' command will list the connected USB devices.  Find the bus and
device number of the printer:

Bus 005 Device 002: ID 03f0:3304 Hewlett-Packard DeskJet 990c
    ^^^        ^^^

and then show me the output of 'getfacl /dev/bus/usb/$bus/$device', like this:

# getfacl /dev/bus/usb/005/002
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/005/002
# owner: root
# group: root
user::rw-
user:tim:rw-
group::r--
group:lp:rw-
mask::rw-
other::r--
Comment 8 Alexey Kuznetsov 2008-05-29 11:44:59 EDT
[root@mini axet]# /sbin/lsusb |grep 1020
Bus 001 Device 002: ID 03f0:2b17 Hewlett-Packard LaserJet 1020


[root@mini axet]# getfacl /dev/bus/usb/001/002
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/002
# owner: root
# group: root
user::rw-
group::r--
mask::r--
other::r--

[root@mini axet]# 


i work under vncserver :), probably udev make a fault to recognize me as normal
user...
Comment 9 Tim Waugh 2008-05-30 05:31:05 EDT
There should still be an 'lp' ACL on that device -- that's what's preventing
hplip from accessing it.

Please do this:

$ lshal > hal.txt

and attach the hal.txt file to this bug report.  Thanks.
Comment 10 Alexey Kuznetsov 2008-05-30 08:34:44 EDT
Created attachment 307193 [details]
lshal
Comment 11 Tim Waugh 2008-05-30 11:49:55 EDT
Hmm, looks like you ought to get the 'lp' group added to that device node:

udi = '/org/freedesktop/Hal/devices/usb_device_3f0_2b17_JL2NBET'
  access_control.file = '/dev/bus/usb/001/002'  (string)
  access_control.grant_group = {'lp'} (string list)
  access_control.type = 'scanner'  (string)

but for some reason it isn't happening.

What does 'rpm -q udev' say, and does 'rpm -V udev' give any output?
Comment 12 Tim Waugh 2008-05-30 11:53:33 EDT
Another thing to try just as a test is:

setfacl -m g:lp:rw /dev/bus/usb/001/002

This should at least let you print..
Comment 13 Alexey Kuznetsov 2008-05-30 11:58:02 EDT
vncserver that can affect on my real user 'axet' rights. for example i ('axet')
dont have write permission on sound devices. but that MUST NOT affect printing 
system as i understand server archeticture.

[axet@mini ~]$ ll /dev/dsp 
crw-rw---- 1 root root 14, 3 2008-05-29 17:17 /dev/dsp
[axet@mini ~]$ 


details what you request:

[root@mini axet]# rpm -q udev
udev-120-5.20080421git.fc9.ppc
[root@mini axet]# rpm -V udev
[root@mini axet]# 

note:i use PPC arch (mac mini with fedora 9)
Comment 14 Alexey Kuznetsov 2008-05-30 11:58:50 EDT
[root@mini axet]# setfacl -m g:lp:rw /dev/bus/usb/001/002
[root@mini axet]# 

[axet@mini ~]$ setfacl -m g:lp:rw /dev/bus/usb/001/002
setfacl: /dev/bus/usb/001/002: Operation not permitted
Comment 15 Alexey Kuznetsov 2008-05-30 12:01:19 EDT
[axet@mini ~]$ setfacl -m g:lp:rw /dev/bus/usb/001/002
setfacl: /dev/bus/usb/001/002: Operation not permitted
[root@mini axet]# 

[root@mini axet]# setfacl -m g:lp:rw /dev/bus/usb/001/002
[root@mini axet]# 

[axet@mini ~]$ setfacl -m g:lp:rw /dev/bus/usb/001/002
[axet@mini ~]$ 

after that i try print simple document trougth gedit , but get error on toolbar:
"Printer error, There is a problem on printer"
Comment 16 Tim Waugh 2008-05-30 12:07:48 EDT
Can you try using the troubleshooter again, as in comment #1, after running the
'setfacl' command as root?
Comment 17 Alexey Kuznetsov 2008-05-30 12:14:23 EDT
Created attachment 307211 [details]
troubleshoot after setfacl
Comment 18 Tim Waugh 2008-05-30 16:49:14 EDT
Is there anything in /var/log/messages from around the same time as this message?:

D [30/May/2008:20:13:18 +0400] [Job 28] prnt/backend/hp.c 561: ERROR: 32 other;
will retry in 30 seconds...
Comment 19 Alexey Kuznetsov 2008-05-30 19:40:08 EDT
No :( here is first ERROR 32 occur:

May 30 19:57:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 30 19:57:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 30 19:57:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 30 19:57:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 30 19:57:45 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 30 19:57:45 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 30 19:57:45 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 30 19:57:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 30 19:58:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135:
unable get_string_descriptor -1: Operation not permitted
May 30 19:58:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603:
invalid product id string ret=-1
May 30 19:58:15 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057:
unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
May 30 19:58:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636:
INFO: open device failed; will retry in 30 seconds...
May 30 19:58:45 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/hpmud.c 604:
invalid channel_write state
May 30 19:58:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 19:59:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 19:59:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:00:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:00:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:01:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:01:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:02:15 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:02:45 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:02:53 mini ntpd[2235]: time reset +2.647270 s
May 30 20:03:18 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
May 30 20:03:48 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 561:
ERROR: 32 other; will retry in 30 seconds...
Comment 20 Tim Waugh 2008-06-04 07:10:47 EDT
That error seems to be coming from the device.

What does 'hp-info' say after you run the 'setfacl' command? (Note, you'll need
to run 'setfacl' again, re-checking the bus/device numbers with 'lsusb', after
rebooting.)
Comment 21 Alexey Kuznetsov 2008-06-04 15:27:37 EDT
Created attachment 308385 [details]
hp-info
Comment 22 Alexey Kuznetsov 2008-06-05 02:39:55 EDT
last hp-info doned from root, from normal user i got same error as in first
message with hp-info.
Comment 23 Tim Waugh 2008-06-05 05:24:36 EDT
I think there might be two problems here:

1. There seems to be a device permissions problem: for some reason the ACL on
the USB device node is either not getting set, or is getting reset.  This might
be to do with your ppc architecture.

2. The HP LaserJet 1020 may need some sort of additional/proprietary software to
drive it, according to the documentation in HPLIP 2.8.5: "This printer REQUIRES
a downloadable driver plug-in".

I think we need to try to get to the bottom of the permissions problem first. 
What does 'ls /usr/share/hal/fdi/policy/10osvendor/' say?




Comment 24 Alexey Kuznetsov 2008-06-05 15:15:48 EDT
[axet@mini ~]$ ll /usr/share/hal/fdi/policy/10osvendor/
total 748
-rw-r--r-- 1 root root    266 2008-05-10 00:19 10-cpufreq.fdi
-rw-r--r-- 1 root root    720 2008-05-10 00:19 10-dockstation.fdi
-rw-r--r-- 1 root root    856 2008-05-12 19:07 10-hal_lpadmin.fdi
-rw-r--r-- 1 root root    761 2008-04-04 20:44 10-hplip.fdi
-rw-r--r-- 1 root root    507 2008-05-10 00:19 10-ibm-buttons.fdi
-rw-r--r-- 1 root root    795 2008-05-10 00:19 10-input-policy.fdi
-rw-r--r-- 1 root root    894 2008-05-10 00:19 10-keymap.fdi
-rw-r--r-- 1 root root   1352 2008-05-10 00:19 10-laptop-panel-mgmt-policy.fdi
-rw-r--r-- 1 root root   3929 2008-05-10 00:19 10-power-mgmt-policy.fdi
-rw-r--r-- 1 root root   1153 2008-05-10 00:19 10-rfkill-switch.fdi
-rw-r--r-- 1 root root    913 2008-05-10 00:19 10-tabletPCs.fdi
-rw-r--r-- 1 root root    460 2008-05-10 00:19 10-toshiba-buttons.fdi
-rw-r--r-- 1 root root    237 2008-05-10 00:19 10-usbcsr-mice.fdi
-rw-r--r-- 1 root root    906 2008-05-10 00:19 10-x11-input.fdi
-rw-r--r-- 1 root root   1214 2008-05-10 00:19 15-storage-luks.fdi
-rw-r--r-- 1 root root 663564 2008-03-27 13:44 19-libsane.fdi
-rw-r--r-- 1 root root   6400 2008-05-10 00:19 20-acl-management.fdi
-rw-r--r-- 1 root root  19472 2008-05-10 00:19 20-storage-methods.fdi
-rw-r--r-- 1 root root   1609 2008-05-10 00:19 30-wol.fdi
[axet@mini ~]$
Comment 25 Tim Waugh 2008-06-06 08:42:57 EDT
Great, thanks.  All looks well there.  Next step is to find out what hal is
actually up to.

Please do this:

1. Disconnect the printer.
2. Find the PID of hald (not hald-runner)
3. strace 2>hald.txt -f $HALD_PID
4. Connect the printer
5. Ctrl-C the strace, and attach it here.

I'm pretty sure it's hald I'm after, not hald-runner, but I may be wrong.  I'm
looking for a file that contains the string 'hal-acl-tool', so if 'grep hal-acl
hald.txt' doesn't show anything please try again with hald-runner.

Thanks.
Comment 26 Alexey Kuznetsov 2008-06-06 14:51:52 EDT
Created attachment 308558 [details]
hald.txt

strace -f -p 1927 2>hald.txt
Comment 27 Alexey Kuznetsov 2008-06-06 14:54:44 EDT
Created attachment 308559 [details]
hald-runner
Comment 28 Tim Waugh 2008-06-10 06:39:28 EDT
Oh, it's hald-runner that I need after all, and unfortunately the trace in
comment #27 seems to be truncated.  Can you try again, tracing hald-runner, and
leave it for about 20 seconds before stopping strace?  Thanks.
Comment 29 Alexey Kuznetsov 2008-06-10 06:57:36 EDT
Created attachment 308800 [details]
hald-runner.txt

[root@mini axet]# strace -f -p 1996 2> hald-runner.txt
^C^C^C^C^C^C^C^C^C^Z
[1]+  Stopped		      strace -f -p 1996 2> hald-runner.txt
[root@mini axet]# kill -9 1996
[root@mini axet]# 
[root@mini axet]# 
[root@mini axet]# ps
  PID TTY	   TIME CMD
 6560 pts/1    00:00:00 su
 6563 pts/1    00:00:00 bash
25064 pts/1    00:01:07 strace
25109 pts/1    00:00:00 ps
[root@mini axet]# kill -9 25064
[root@mini axet]# 
[1]+  Killed		      strace -f -p 1996 2> hald-runner.txt
[root@mini axet]#
Comment 30 Alexey Kuznetsov 2008-06-10 06:58:26 EDT
no problem. thank you for help!
Comment 31 Tim Waugh 2008-06-10 07:08:39 EDT
Well, this has indeed set an ACL:

[pid 25072] execve("/usr/bin/setfacl", ["setfacl"..., "-m"..., "g:7:rw"...,
"/dev/bus/usb/001/004"...], [/* 51 vars */]) = 0

but not necessarily on the device node we were expecting.  What does 'lsusb;
getfacl /dev/bus/usb/001/004' say?
Comment 32 Alexey Kuznetsov 2008-06-10 07:13:43 EDT
look fine...

[root@mini axet]# lsusb
Bus 001 Device 004: ID 03f0:2b17 Hewlett-Packard LaserJet 1020
Bus 001 Device 003: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8204 Apple, Inc. Bluetooth HCI [Bluetooth 2.0 + EDR,
build-in]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[root@mini axet]# getfacl /dev/bus/usb/001/004
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/004
# owner: root
# group: root
user::rw-
group::r--
group:lp:rw-
mask::rw-
other::r--

[root@mini axet]# 
Comment 33 Alexey Kuznetsov 2008-06-10 07:30:09 EDT
what interesting. problem self solved only on second cabel plug in. first
connection got wrong results:

[axet@mini ~]$ lsusb
Bus 001 Device 002: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8204 Apple, Inc. Bluetooth HCI [Bluetooth 2.0 + EDR,
build-in]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[axet@mini ~]$ su
Password: 
[root@mini axet]# lsusb
Bus 001 Device 003: ID 03f0:2b17 Hewlett-Packard LaserJet 1020
Bus 001 Device 002: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8204 Apple, Inc. Bluetooth HCI [Bluetooth 2.0 + EDR,
build-in]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[root@mini axet]# getfacl /dev/bus/usb/001/003 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/003
# owner: root
# group: root
user::rw-
group::r--
other::r--


second connection:

[root@mini axet]# lsusb
Bus 001 Device 004: ID 03f0:2b17 Hewlett-Packard LaserJet 1020
Bus 001 Device 002: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8204 Apple, Inc. Bluetooth HCI [Bluetooth 2.0 + EDR,
build-in]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[root@mini axet]# getfacl /dev/bus/usb/001/004 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/004
# owner: root
# group: root
user::rw-
group::r--
group:lp:rw-
mask::rw-
other::r--

[root@mini axet]# 
Comment 34 Alexey Kuznetsov 2008-06-10 08:18:57 EDT
Created attachment 308801 [details]
hald-runner.txt

duble cable connection:

[root@mini axet]# ps aux|grep hald
68	  1900	0.3  0.4   9032  4692 ?        Ss   16:09   0:00 hald
root	  1966	0.0  0.1   4844  1380 ?        S    16:09   0:00 hald-runner
root	  1991	0.0  0.1   5020  1516 ?        S    16:09   0:00
hald-addon-input: Listening on /dev/input/event1
root	  2001	0.0  0.1   4992  1352 ?        S    16:09   0:00
hald-addon-storage: polling /dev/hdb (every 16 sec)
root	  2811	0.0  0.0   4468   828 pts/1    S+   16:11   0:00 grep hald
[root@mini axet]# history 
[root@mini axet]# strace -f -p 1966 2> hald-runner.txt
^C^C^C^C^C^C^Z
[1]+  Stopped		      strace -f -p 1966 2> hald-runner.txt
[root@mini axet]# kill -9 
[root@mini axet]# ps
  PID TTY	   TIME CMD
 2753 pts/1    00:00:00 su
 2777 pts/1    00:00:00 bash
 2812 pts/1    00:01:07 strace
 2997 pts/1    00:00:00 ps
[root@mini axet]# kill -9 2812
[root@mini axet]# 
[1]+  Killed		      strace -f -p 1966 2> hald-runner.txt
[root@mini axet]# lsusb
Bus 001 Device 004: ID 03f0:2b17 Hewlett-Packard LaserJet 1020
Bus 001 Device 002: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05ac:8204 Apple, Inc. Bluetooth HCI [Bluetooth 2.0 +
EDR, build-in]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[root@mini axet]# getfacl  /dev/bus/usb/001/004
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/004
# owner: root
# group: root
user::rw-
group::r--
group:lp:rw-
mask::rw-
other::r--

[root@mini axet]#
Comment 35 Alexey Kuznetsov 2008-06-10 08:20:21 EDT
Created attachment 308803 [details]
hald-runner.message.log

/var/log/messager for double cable connection
Comment 36 Alexey Kuznetsov 2008-06-10 21:52:13 EDT
As you can see in Comment #27 and in Comment #34 in booth cases log truncated,
that mean hald-runner stuck in first cable connection. And that explain why
hald-runner do not set group flags properly after system reboot.
Comment 37 Tim Waugh 2008-06-11 04:16:12 EDT
Looks like both strace logs stop while trying to read directory entries for a
particular directory.

What does this command say?:

ls /usr/lib/python2.5/site-packages
Comment 38 Alexey Kuznetsov 2008-06-11 13:24:39 EDT
[root@mini axet]# ls /usr/lib/python2.5/site-packages
acutilmodule.so                  Paste-1.6-py2.5-nspkg.pth
Alacarte                         pcardext.la
audit.py                         pcardext.so
audit.pyc                        PIL
audit.pyo                        PIL.pth
_audit.so                        pkg_resources.py
auparse-1.0-py2.5.egg-info       pkg_resources.pyc
auparse.so                       pkg_resources.pyo
BitTorrent                       planner.la
BitTorrent-4.4.0-py2.5.egg-info  planner.so
btctl.so                         plannerui.la
cairo                            plannerui.so
codeina                          PortableServer.py
CORBA.py                         PortableServer.pyc
CORBA.pyc                        PortableServer.pyo
CORBA.pyo                        pyatspi
Crypto                           pycrypto-2.0.1-py2.5.egg-info
cups-1.0-py2.5.egg-info          pygpgme-0.1-py2.5.egg-info
cupsext.la                       pygst.pth
cupsext.so                       pygst.py
cups.so                          pygst.pyc
dbus                             pygst.pyo
dbus_bindings.py                 pygtk.pth
dbus_bindings.pyc                pygtk.py
dbus_bindings.pyo                pygtk.pyc
_dbus_bindings.so                pygtk.pyo
_dbus_glib_bindings.so           pyisomd5sum.so
drv_libxml2.py                   PyOpenGL-3.0.0b1-py2.5.egg-info
drv_libxml2.pyc                  pyqtconfig.py
drv_libxml2.pyo                  pyqtconfig.pyc
dsml.py                          pyqtconfig.pyo
dsml.pyc                         python_ldap-2.3.1-py2.5.egg-info
firstboot                        pyxdg-0.15-py2.5.egg-info
firstboot-1.97-py2.5.egg-info    qtcanvas.so
_gamin.a                         qtgl.so
_gamin.la                        qtnetwork.so
gamin.py                         qt.so
gamin.pyc                        qtsql.so
gamin.pyo                        qttable.so
_gamin.so                        qtui.so
genshi                           qtxml.so
Genshi-0.4.4-py2.5.egg-info      README
glchess                          reportlab
gmenu.so                         Reportlab-2.1-py2.5.egg-info
gnomebt                          rhpl
gnome_sudoku                     rhpxl
gpgme                            rhpxl-1.9-py2.5.egg-info
gpspacket.so                     rpm
gps.py                           rpmUtils
gps.pyc                          scanext.la
gps.pyo                          scanext.so
gst-0.10                         selinux
gtk-2.0                          semanage.py
gtksourceview2.so                semanage.pyc
hpmudext.la                      semanage.pyo
hpmudext.so                      _semanage.so
iniparse                         seobject.py
iniparse-0.2.3-py2.5.egg-info    seobject.pyc
invest                           seobject.pyo
ixf86configmodule.so             sepolgen
khashmir                         setroubleshoot
_kudzumodule.so                  setuptools
kudzu.py                         setuptools-0.6c7-py2.5.egg-info
kudzu.pyc                        sipconfig.py
kudzu.pyo                        sipconfig.pyc
ldap                             sipconfig.pyo
_ldap.so                         sipdistutils.py
ldapurl.py                       sipdistutils.pyc
ldapurl.pyc                      sipdistutils.pyo
ldif.py                          sip.so
ldif.pyc                         site.py
libsvn                           site.pyc
libusermodule.so                 site.pyo
libxml2mod.a                     _snackmodule.so
libxml2mod.la                    snack.py
libxml2mod.so                    snack.pyc
libxml2.py                       snack.pyo
libxml2.pyc                      spambayes
libxml2.pyo                      spambayes-1.0.4-py2.5.egg-info
mod_python                       sqlitecachec.py
mod_python-3.3.1-py2.5.egg-info  sqlitecachec.pyc
Numeric                          sqlitecachec.pyo
Numeric.pth                      _sqlitecache.so
OpenGL                           svn
opensync.py                      urlgrabber
opensync.pyc                     urlgrabber-3.0.0-py2.5.egg-info
opensync.pyo                     xdg
_opensync.so                     xf86config.py
ORBit.so                         xf86config.pyc
orca                             xf86config.pyo
packagekit                       yum
paste                            yum_metadata_parser-1.1.2-py2.5.egg-info
Paste-1.6-py2.5.egg-info         yum_presto-0.4.4-py2.5.egg-info
[root@mini axet]# 

Comment 39 Tim Waugh 2008-06-12 11:04:03 EDT
Hm.  How long did you leave it before stopping strace?  You might need to leave
it for longer.
Comment 40 Alexey Kuznetsov 2008-06-13 00:00:46 EDT
Leave what? strace by ctrl+c? about 1-2 minutes. In another case i wait whole
time boot, and more (one hour, one day), and still dont get right group permissions
Comment 41 Tim Waugh 2008-06-13 06:16:38 EDT
I meant leave strace running for longer, but actually looking more closely at
the logs I don't think it would help.

For the 'success' log from comment #29 we see this sequence:

/usr/libexec/hal-acl-tool --add-device
/usr/libexec/hald-probe-printer
/usr/libexec/hal_lpadmin --add
(although strangely, it also stop at the very same getdents64() call as the
others, perhaps just taking a long time to read the contents of that directory)

For the 'fail' logs we see this sequence:

/usr/libexec/hald-probe-printer
/usr/libexec/hal_lpadmin --add

So when hal-acl-tool does get run it happens first of all.

Now that I take another look at it, the strace of the main 'hald' process looks
wrong:

poll([{fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=11,
events=POLLIN|POLLPRI}, {fd=12, events=POLLPRI}, {fd=13, events=POLLIN}, {fd=15,
events=0}, {fd=7, events=POLLIN}, {fd=16, events=POLLIN}, {fd=8, events=POLLIN},
{fd=14, events=POLLIN, revents=POLLIN}, {fd=10, events=POLLIN}, {fd=17,
events=POLLIN}], 12, 1998) = 1
recvmsg(14, {msg_name(0)=NULL,
msg_iov(1)=[{"add@/devices/pci0001:10/0001:10:"..., 4096}], msg_controllen=24,
{cmsg_len=24, cmsg_level=SOL_SOCKET, cmsg_type=SCM_CREDENTIALS{pid=18382, uid=0,
gid=0}}, msg_flags=0}, 0) = 306
readlink("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/subsystem",
"../../../../../bus/usb", 511) = 22
stat64("/sys/devices/pci0001:10/0001:10:1b.2/usb1/driver",
{st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
readlink("/sys/devices/pci0001:10/0001:10:1b.2/usb1/driver",
"../../../../bus/usb/drivers/usb", 255) = 31
stat64("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/driver", 0xbfd8ac20) = -1
ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/configuration",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bConfigurationValue",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bNumConfigurations",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bNumInterfaces",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bDeviceClass",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bDeviceSubClass",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bDeviceProtocol",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/idVendor",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/idProduct",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/manufacturer",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/product",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bcdDevice",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bMaxPower",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/maxchild",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/devnum",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/serial",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/speed",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/version",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/sys/devices/pci0001:10/0001:10:1b.2/usb1/1-1/bmAttributes",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)

Those open calls all succeed for me.  I'm wondering if that's the cause.

Reassigning to hal for further analysis.
Comment 42 David Zeuthen 2008-06-13 10:16:16 EDT
Is SELinux in permissive or enforcing mode? If in enforcing, does putting the
machine in permissive mode helps?
Comment 43 Alexey Kuznetsov 2008-06-13 10:26:45 EDT
for all up follow comments i put selinux to disable mode. but for now i enable
it back.
Comment 44 Alexey Kuznetsov 2008-06-26 18:17:53 EDT
i try install printer on fedora 8 with selinux disabled, everything work fine :(
Comment 45 Alexey Kuznetsov 2008-06-27 03:21:06 EDT
work fine on fedora 9 i386.
Comment 46 Alexey Kuznetsov 2008-08-10 13:36:28 EDT
I tried to use foo2zjs package from livna.org repository. I still unable to print until i reconnect my usb printer cable. After i replug cable everything working fine and i able to print. Look like here is two problem one with printer driver other with hal.
Comment 47 Alexey Kuznetsov 2008-08-10 13:42:49 EDT
Aug 10 21:40:28 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Aug 10 21:40:28 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-1
Aug 10 21:40:28 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1057: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Aug 10 21:40:28 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 636: INFO: open device failed; will retry in 30 seconds...
Aug 10 21:40:29 mini foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600 -p9 -s7 -m1 -n1
Aug 10 21:40:53 mini kernel: usb 1-1: USB disconnect, address 2
Aug 10 21:40:54 mini kernel: usb 1-1: new high speed USB device using ehci_hcd and address 4
Aug 10 21:40:55 mini kernel: usb 1-1: configuration #1 chosen from 1 choice
Aug 10 21:40:55 mini kernel: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
Aug 10 21:40:55 mini kernel: usb 1-1: New USB device found, idVendor=03f0, idProduct=2b17
Aug 10 21:40:55 mini kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug 10 21:40:55 mini kernel: usb 1-1: Product: HP LaserJet 1020
Aug 10 21:40:55 mini kernel: usb 1-1: Manufacturer: Hewlett-Packard
Aug 10 21:40:55 mini kernel: usb 1-1: SerialNumber: JL2NBET
Aug 10 21:40:55 mini logger: loading hp_laserjet_1020 firmware 001 004
Aug 10 21:40:57 mini python: hp-makeuri[2897]: error: Device does not support fax.
Aug 10 21:40:58 mini kernel: usblp0: removed
Aug 10 21:41:05 mini python: io/hpmud/musb.c 135: unable get_string_descriptor -110: Connection timed out
Aug 10 21:41:05 mini python: io/hpmud/musb.c 2035: invalid product id string ret=-110
Aug 10 21:41:08 mini python: hp-makeuri[2923]: error: Device not found
Aug 10 21:41:08 mini python: hp-makeuri[2929]: error: Device does not support fax.
Aug 10 21:41:10 mini foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600 -p9 -s7 -m1 -n1
Aug 10 21:41:12 mini foo2zjs-wrapper: gs -sPAPERSIZE=a4 -g9920x7016 -r1200x600 -sDEVICE=pbmraw -dCOLORSCREEN  
Aug 10 21:41:12 mini foo2zjs-wrapper: foo2zjs -r1200x600 -g9920x7016 -p9 -m1 -n1 -d1 -s7 -z1  -u 192x96 -l 192x96 -L 0     -P
Comment 48 Alexey Kuznetsov 2008-11-27 07:45:58 EST
same for fedora 10 ppc.
Comment 49 Alexey Kuznetsov 2008-12-03 11:29:36 EST
Dec  3 19:25:55 mini hal_lpadmin: Added printer HP-LaserJet-1020
Dec  3 19:26:14 mini restorecond: Will not restore a file with more than one har
d link (/etc/resolv.conf) No such file or directory
Dec  3 19:26:44 mini hpijs: unable to open PrintContext object err=16
Dec  3 19:26:53 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/hpmud.c 608: inva
lid channel_write state
Dec  3 19:26:53 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 594: ERR
OR: 671122498 other; will retry in 30 seconds...
Dec  3 19:27:01 mini hpijs: unable to open PrintContext object err=16
Dec  3 19:27:10 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/hpmud.c 608: inva
lid channel_write state
Dec  3 19:27:10 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 594: ERR
OR: 671122498 other; will retry in 30 seconds...
Dec  3 19:27:40 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 594: ERR
OR: 671122498 other; will retry in 30 seconds...
Comment 50 Tim Waugh 2008-12-03 11:49:39 EST
This is Fedora 10 now by the look of it.

It seems that err=16 means 'unsupported printer'.  Can you try running 'hp-setup' to create the queue and see if that makes any difference?
Comment 51 Alexey Kuznetsov 2008-12-03 12:15:08 EST
Downloading firmware to device hp:/usb/HP_LaserJet_1020?serial=JL2NBET...
Firmware download successful.


Done.
[axet@mini ~]$ 


reboot









Dec  3 20:12:41 mini cupsd[2230]: *** WARNING *** The program 'cupsd' uses the Apple Bonjour compatibility layer of Avahi.
Dec  3 20:12:41 mini cupsd[2230]: *** WARNING *** Please fix your application to use the native API of Avahi!
Dec  3 20:12:41 mini cupsd[2230]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=cupsd>
Dec  3 20:12:42 mini avahi-daemon[2198]: Service "mini samba" (/services/samba.service) successfully established.
Dec  3 20:12:42 mini avahi-daemon[2198]: Service "mini sftp" (/services/sftp.service) successfully established.
Dec  3 20:12:42 mini avahi-daemon[2198]: Service "mini" (/services/ssh.service) successfully established.
Dec  3 20:12:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Dec  3 20:12:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-1
Dec  3 20:12:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:12:42 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Dec  3 20:12:42 mini avahi-daemon[2198]: Registering new address record for fe80::64f1:94ff:fe75:c6af on virbr0.*.
Dec  3 20:12:44 mini ntpd[2042]: Listening on interface #6 virbr0, fe80::64f1:94ff:fe75:c6af#123 Enabled
Dec  3 20:12:44 mini ntpd[2042]: Listening on interface #7 virbr0, 192.168.122.1#123 Enabled
Dec  3 20:12:46 mini hpijs: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Dec  3 20:12:46 mini hpijs: io/hpmud/musb.c 603: invalid product id string ret=-1
Dec  3 20:12:46 mini hpijs: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:12:46 mini hpijs: unable to set device=HP LaserJet 1020, err=16
Dec  3 20:12:46 mini hpijs: unable to read client data err=-2
Dec  3 20:13:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Dec  3 20:13:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-1
Dec  3 20:13:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:13:12 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Dec  3 20:13:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Dec  3 20:13:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-1
Dec  3 20:13:42 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:13:42 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Dec  3 20:14:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Dec  3 20:14:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-1
Dec  3 20:14:12 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:14:12 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
(END)
Comment 52 Alexey Kuznetsov 2008-12-03 12:17:23 EST
replugging cable:

Dec  3 20:15:29 mini kernel: usb 1-2: USB disconnect, address 3
Dec  3 20:15:35 mini kernel: usb 1-2: new high speed USB device using ehci_hcd and address 4
Dec  3 20:15:35 mini kernel: usb 1-2: configuration #1 chosen from 1 choice
Dec  3 20:15:35 mini kernel: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
Dec  3 20:15:35 mini kernel: usb 1-2: New USB device found, idVendor=03f0, idProduct=2b17
Dec  3 20:15:35 mini kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec  3 20:15:35 mini kernel: usb 1-2: Product: HP LaserJet 1020
Dec  3 20:15:35 mini kernel: usb 1-2: Manufacturer: Hewlett-Packard
Dec  3 20:15:35 mini kernel: usb 1-2: SerialNumber: JL2NBET
Dec  3 20:15:35 mini logger: loading hp_laserjet_1020 firmware 001 004
Dec  3 20:15:36 mini python: hp-firmware[2401]: warning: hp-firmware should not be run as root.
Dec  3 20:15:38 mini python: hp-makeuri[2422]: warning: hp-makeuri should not be run as root.
Dec  3 20:15:38 mini python: hp-makeuri[2426]: warning: hp-makeuri should not be run as root.
Dec  3 20:15:38 mini python: hp-makeuri[2426]: error: Device does not support fax.
Dec  3 20:15:39 mini kernel: usblp0: removed
Dec  3 20:15:41 mini python: hp-makeuri[2452]: warning: hp-makeuri should not be run as root.
Dec  3 20:15:46 mini python: io/hpmud/musb.c 135: unable get_string_descriptor -110: Connection timed out
Dec  3 20:15:46 mini python: io/hpmud/musb.c 2038: invalid product id string ret=-110
Dec  3 20:15:47 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 135: unable get_string_descriptor -110: Connection timed out
Dec  3 20:15:47 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 603: invalid product id string ret=-110
Dec  3 20:15:48 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/musb.c 1058: unable to open hp:/usb/HP_LaserJet_1020?serial=JL2NBET
Dec  3 20:15:48 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Dec  3 20:15:49 mini python: hp-makeuri[2452]: error: Device not found
Dec  3 20:15:49 mini python: hp-makeuri[2456]: warning: hp-makeuri should not be run as root.
Dec  3 20:15:49 mini python: hp-makeuri[2456]: error: Device does not support fax.
Dec  3 20:15:49 mini hal_lpadmin: Disabled printer HP-LaserJet-1020, as the corresponding device was unplugged or turned off
Dec  3 20:16:18 mini HP_LaserJet_1020?serial=JL2NBET: io/hpmud/hpmud.c 608: invalid channel_write state
Dec  3 20:16:18 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 594: ERROR: 671122498 other; will retry in 30 seconds...
Dec  3 20:16:48 mini HP_LaserJet_1020?serial=JL2NBET: prnt/backend/hp.c 594: ERROR: 671122498 other; will retry in 30 seconds...
Comment 53 Alexey Kuznetsov 2009-01-05 09:52:27 EST
Friends!

For 1 year i unable to use my printer on PPC machine. Last distro which works with HP-1020 was Fedora 8 ppc and for ow i unable to work with my printer.

I made simple tests and report it here in this bug. As result i can summarize: fedora 9 and fedora 10 ppc build have bug in booth hal and printer drivers. But fedora 9 and fedora 10 i386 build works fine, without any troubles.

I ask you, my friends, to give me some tests which i can run on booth fedora PPC and feodra i386 to diagnose current state and find the place where bug live! That is can be some strace logs, system logs which i can run on my booth machines my ppc server and my notebook and finely we can find the point where bug persist.

thx!
Comment 54 Alexey Kuznetsov 2009-03-07 16:21:31 EST
Created attachment 334422 [details]
usbmon log for ppc machine (bad)
Comment 55 Alexey Kuznetsov 2009-03-07 16:22:48 EST
Created attachment 334423 [details]
usbmon log for i386 (good)
Comment 56 Alexey Kuznetsov 2009-03-07 16:27:01 EST
booth logs for usb cable connect. after i connect usb cable to i386 machine everything works fine, without hp-setup run. after i connect same printer to ppc machine everything bad.

logs almost similar, except this part, which present only for i386 machine:

f64a8900 2604104934 S Ci:1:010:0 s 80 06 0302 0409 00ff 255 <
f64a8900 2604105087 C Ci:1:010:0 0 34 = 22034800 50002000 4c006100 73006500 72004a00 65007400 20003100 30003200
f64a8900 2604105137 S Ci:1:010:0 s 80 06 0303 0409 00ff 255 <
f64a8900 2604105330 C Ci:1:010:0 0 16 = 10034a00 4c003200 4e004200 45005400
Comment 57 Alexey Kuznetsov 2009-06-12 07:31:30 EDT
same as in 2008. i found my hp1020 printer half working with foo2zjs-0.20080826-3.fc11.ppc package.

with hpljs ppd file printer wont work completely.

with foo2zjs ppd file printer work after cable replugging.
Comment 58 Alexey Kuznetsov 2009-08-06 11:34:21 EDT
latest updates:

[root@mini axet]# tailf /var/log/messages
Aug  6 19:31:40 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:31:40 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:31:40 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 79
Aug  6 19:31:41 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:31:41 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:31:41 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 80
Aug  6 19:31:41 mini kernel: usb 2-1: device not accepting address 80, error -62
Aug  6 19:31:42 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 81
Aug  6 19:31:42 mini kernel: usb 2-1: device not accepting address 81, error -62
Aug  6 19:31:42 mini kernel: hub 2-0:1.0: unable to enumerate USB device on port 1
Aug  6 19:32:22 mini kernel: usb 1-2: USB disconnect, address 3
Aug  6 19:32:25 mini kernel: usb 1-2: new high speed USB device using ehci_hcd and address 4
Aug  6 19:32:25 mini kernel: usb 1-2: New USB device found, idVendor=03f0, idProduct=2b17
Aug  6 19:32:25 mini kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug  6 19:32:25 mini kernel: usb 1-2: Product: HP LaserJet 1020
Aug  6 19:32:25 mini kernel: usb 1-2: Manufacturer: Hewlett-Packard
Aug  6 19:32:25 mini kernel: usb 1-2: SerialNumber: JL2NBET
Aug  6 19:32:25 mini kernel: usb 1-2: configuration #1 chosen from 1 choice
Aug  6 19:32:25 mini kernel: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
Aug  6 19:32:25 mini logger: loading hp_laserjet_1020 firmware 001 004
Aug  6 19:32:25 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 82
Aug  6 19:32:25 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:32:25 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:32:26 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 83
Aug  6 19:32:26 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:32:26 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:32:26 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 84
Aug  6 19:32:27 mini kernel: usb 2-1: device not accepting address 84, error -62
Aug  6 19:32:27 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 85
Aug  6 19:32:27 mini kernel: usb 2-1: device not accepting address 85, error -62
Aug  6 19:32:27 mini kernel: hub 2-0:1.0: unable to enumerate USB device on port 1
Aug  6 19:32:28 mini hal_lpadmin: Printer HP_LaserJet_1020 exists but is disabled, reason: Processing page 2...; use 'cupsenable HP_LaserJet_1020' to enable it
Aug  6 19:32:30 mini kernel: usblp0: removed


----> call cupsenable HP_LaserJet_1020


Aug  6 19:32:59 mini HP_LaserJet_1020: prnt/hpijs/hpcups.cpp 382: ERROR: unable to set device = HP LaserJet 1018, err = 48
Aug  6 19:32:59 mini HP_LaserJet_1020: prnt/hpijs/hpcups.cpp 676: hpcups: returning status 1 from main
Aug  6 19:32:59 mini hp[3310]: prnt/backend/hp.c 802: ERROR: null print job total=0
Aug  6 19:32:59 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 86
Aug  6 19:33:00 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:33:00 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:33:00 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 87
Aug  6 19:33:00 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:33:00 mini kernel: usb 2-1: device descriptor read/64, error -62
Aug  6 19:33:01 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 88
Aug  6 19:33:01 mini kernel: usb 2-1: device not accepting address 88, error -62
Aug  6 19:33:01 mini kernel: usb 2-1: new full speed USB device using ohci_hcd and address 89
Aug  6 19:33:02 mini kernel: usb 2-1: device not accepting address 89, error -62
Aug  6 19:33:02 mini kernel: hub 2-0:1.0: unable to enumerate USB device on port 1
Comment 59 Tim Waugh 2009-08-06 11:48:39 EDT

*** This bug has been marked as a duplicate of bug 505647 ***
Comment 60 Alexey Kuznetsov 2009-08-06 11:59:56 EDT
i hope if this bug is dupliate o 505647. but i never had printer worked on my PPC system.
Comment 61 Tim Waugh 2009-08-06 12:05:25 EDT
I believe the permissions problem is the duplicate.

The remainder of the problem is that there is no complete free software driver for your printer.
Comment 62 Alexey Kuznetsov 2009-08-06 12:29:39 EDT
now my printer works fine with foo2zjs driver, and with fixes from 505647(reboot issue).

but no default hp driver works. reopen or not?
Comment 63 Tim Waugh 2009-08-06 12:41:15 EDT
HPLIP does not support this device without proprietary software (the "plugin"). :-(
Comment 64 Alexey Kuznetsov 2009-08-06 12:47:19 EDT
with out his plugin it works fine with foo2zjs package. when i used hp-setup to setup my hp1020 as hp printer it wont work (with hp binary plugin, it autodownloaded from hp site).
Comment 65 Tim Waugh 2009-08-07 04:17:18 EDT
We can't ship foo2zjs in Fedora due to patent concerns.

Note You need to log in before you can comment on or make changes to this bug.