Bug 446704 - Add/Remove Software doesn't allow install or remove of packages
Add/Remove Software doesn't allow install or remove of packages
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-15 14:26 EDT by eric@christensenplace.us
Modified: 2008-06-03 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-03 09:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2008-05-15 14:26:12 EDT
Description of problem: When I go to Add/Remove Software, and I see a package I
want to install or remove, I click on the "Install" or the "Remove" button but
nothing happens.

Version-Release number of selected component (if applicable): gpk-application 0.1.12

How reproducible: Very (had this on multiple installations of F9 from the Live CD).

Steps to Reproduce:
1. Open Add/Remove Software
2. Select a package
3. Select "Install" or "Remove"
Actual results:
Nothing happens.

Expected results:
Package should be installed or removed.

Additional info:
Comment 1 Henri Ala-Peijari 2008-05-17 08:29:21 EDT
This problem also exists on my 64-bit Fedora 9 installation on an Intel Q9300 &
DG33FBC motherboard. Maybe it's somehow related to the problem that I couldn't
install the additional software like I'm used to (repository not found or
something...) during the Fedora 9 installation from the DVD?
Comment 2 yhjsnd 2008-05-19 08:20:55 EDT
I have the similar problem,in addition, when I add/remove software and click on
items on the left, nothing appear on the right, but when I search packet by
entering a name and clicking the find button, a lot of packets appear.
Comment 3 malcolm 2008-05-20 10:22:26 EDT
Me too, However it did work with the version that's on the release DVD
and has subsequently stopped in the last day or so - This is 32 bit 
I have the same problem on a number of intel machines 
Comment 4 Richard Hughes 2008-05-28 05:24:38 EDT
The group list may stop working if you have added other broken repositories. Try
disabling all but the fedora repository in "software sources" and then try
clicking the group list.

For the nothing happens problem, are you sure you're not running as the root user?
Comment 5 Henri Ala-Peijari 2008-05-28 08:01:55 EDT
I tried running it as another user and it worked. Amazing! Now I have to be
non-root to get privileges to run programs? Please don't go the route
SuSe/Freespire and other distros where you have to use hours to figure out how
to run programs because root can't login. 

Comment 6 Richard Hughes 2008-06-03 09:28:52 EDT
Please see http://fedoraproject.org/wiki/PackageKitFaq -- thanks.

Note You need to log in before you can comment on or make changes to this bug.