Bug 446706 - Fedora thinks iPod Touch is a camera
Fedora thinks iPod Touch is a camera
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 14:30 EDT by Steven Garrity
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 12:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the phantom iPod camera (36.19 KB, image/png)
2008-05-15 14:30 EDT, Steven Garrity
no flags Details

  None (edit)
Description Steven Garrity 2008-05-15 14:30:09 EDT
Description of problem:
Fedora seems to link the iPod Touch is a camera, according to the desktop icon
at least.

Version-Release number of selected component (if applicable):
Using fresh install of Fedora 9

How reproducible: always.


Steps to Reproduce:
1. Plugin iPod Touch
2. See camera icon appear on desktop
3. Chuckle?
  
Expected results:
Tango Extras has pretty hardware icons for these. I understand the Apple stuff
is proprietary, but I would think we could at least identify the hardware.


Additional info:
Comment 1 Steven Garrity 2008-05-15 14:30:09 EDT
Created attachment 305516 [details]
Screenshot of the phantom iPod camera
Comment 2 Jonas Nyman 2008-05-15 15:11:53 EDT
Confirmed. Then it is possible to "open" the ipod with an empty window as the
sole result. And Fedora asks if I want to import the photos from the camera,
which is of course nonsense. 

Comment 3 David Zeuthen 2008-05-27 12:07:02 EDT
What's the output of

 gvfs-ls gphoto2://[usb:X,Y]/

(Get the exact URI from this command: gvfs-mount -l)

I'm pretty sure there's a DCIM folder in the root.. which would indicate it's
using the DCF system which is why we pick it up as a camera.
Comment 4 Steven Garrity 2008-05-27 12:15:20 EDT
(In reply to comment #3)
> What's the output of gvfs-ls gphoto2://[usb:X,Y]/
> I'm pretty sure there's a DCIM folder in the root.. which would indicate it's
> using the DCF system which is why we pick it up as a camera.

gvfs-ls gphoto2://[usb:001,009]/ returns nothing - also, when I plug it in,
Nautilus opens the folder and it's empty. I don't have any photos stored on the
iPod, if that makes a difference.

Comment 5 David Zeuthen 2008-05-27 12:41:12 EDT
Right, I just checked the Apple website and there's no built-in camera like on
the iPhone. The reason we pick it up and display it as a camera is because of
the fact that it advertises itself as a PTP device.

My guess is that the iPod Touch is pretty useless as a USB device (unless you're
running OS X or Windows)... until someone manages to reverse engineer the
mechanism used for updating the music player bits. When that happens we have
ways of tagging the device as a music player.

I'm not sure there's a bug here; the device claims to be a PTP device and we
correctly identify it as such. IOW, complain to the vendor of the device. I'm
closing this bug.

Note You need to log in before you can comment on or make changes to this bug.