Bug 446743 - [PATCH] copy DNS information into ifcfg files
[PATCH] copy DNS information into ifcfg files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 16:10 EDT by Dan Williams
Modified: 2008-05-30 22:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.10-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 22:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy info from DNS page into each ifcfg file (3.52 KB, patch)
2008-05-15 16:10 EDT, Dan Williams
no flags Details | Diff
patch refined (2.09 KB, patch)
2008-05-16 07:38 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Dan Williams 2008-05-15 16:10:41 EDT
NetworkManager treats resolv.conf as a composite of DNS information from each
connection, since for things like VPN you want your VPN DNS servers and domain
searches in resolv.conf when you're using the VPN but not when you aren't using
the VPN.  Therefore, resolv.conf is not stable enough to be the only source of
DNS information.

The attached patch makes system-config-network save the DNS information that the
user enters in the DNS page into each device's ifcfg file.  This will be used by
NetworkManager to ensure that after setting static DNS servers with s-c-n, that
you get a workable resolv.conf file.

When _not_ using NetworkManager, there shouldn't be any effect because the DNS
information will be the same for the ifcfg files as in /etc/resolv.conf. 
Currently Dialup devices already use DNS1/DNS2, and thus for dialup devices this
copy is not performed (though it could be).

Thoughts?
Comment 1 Dan Williams 2008-05-15 16:10:41 EDT
Created attachment 305536 [details]
Copy info from DNS page into each ifcfg file
Comment 2 Harald Hoyer 2008-05-16 06:22:30 EDT
wow, thanks very much for the patch :)
Comment 3 Harald Hoyer 2008-05-16 07:38:04 EDT
Created attachment 305675 [details]
patch refined

reduced the patch
Comment 5 Fedora Update System 2008-05-16 08:28:30 EDT
system-config-network-1.5.8-1.fc9 has been submitted as an update for Fedora 9
Comment 6 Dan Williams 2008-05-16 11:51:55 EDT
harald; do you mind if I apply to F8 branch and push as an update for F8 as well?
Comment 7 Fedora Update System 2008-05-17 18:20:24 EDT
system-config-network-1.5.8-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4022
Comment 8 Harald Hoyer 2008-05-20 09:39:12 EDT
please test and give feedback
Comment 9 Fedora Update System 2008-05-27 09:37:26 EDT
system-config-network-1.5.10-1.fc9 has been submitted as an update for Fedora 9
Comment 10 Fedora Update System 2008-05-30 22:15:08 EDT
system-config-network-1.5.10-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.