Bug 446746 - Suggestions for Anaconda (Fedora 10)
Suggestions for Anaconda (Fedora 10)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 16:16 EDT by Couret Charles-Antoine
Modified: 2008-12-10 15:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 15:54:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Couret Charles-Antoine 2008-05-15 16:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Anaconda is the installation software Fedora and I think there are a few things to add. Small changes that will lower my opinion of interest to the comfort they bring.

	
1-In selecting the keyboard, put a bar to test the configuration (particularly useful for the DVD version), especially if one chooses the root password with the wrong configuration ...

2-For the choice of time zone, it happens that is mit on the American continent, for Europeans it is irritating to scroll through the long list to our city. We should be able to type the first letters of the city / country / continent to be over as Nautilus offers to find a file in the current folder on the fly.
Or make several columns (continents and depending on the choice list of cities updates to side).

3-The root password and users are important for security and Fedora is one of the safest distributions. I suggest when choosing passwords a bar showing the effectiveness of passwords, just like Firefox for the main password. (http://img367.imageshack.us/img367/3953/capture1km8.png)

4-Add the keyboard BÉPO-latin9_FR in the list, I myself this keyboard and it is sad not to have upon installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
	 	I am sorry if this is not the right place for this sort of thing but many projects free use BugZilla why ...

Actual Results:


Expected Results:


Additional info:
Comment 1 Jonas Nyman 2008-10-04 14:33:09 EDT
I agree with this. Please include a password safety indicator for the root passwd.

And please include a keyboard test. The F10 beta for instance has a faulty keyboard configuration - but you will probably not realize this until firstboot as it is possible to install using only mouse clicking. 

I also agree with Fedora in general is a bit amerocentric. I believe non-americans find a lot of things irritating. Date and time setting, the non standard nameing of timezones (CET, UTC?). And most people over here speak two or three languages. People may want to use both latin and cyrillic at the same time... We use week numbers in calendars and so on...
Comment 2 Andy Lindeberg 2008-10-06 15:36:14 EDT
We already have a warning that pops up when the root password you have typed in is insecure for whatever reason - is this not sufficient?
Comment 3 Couret Charles-Antoine 2008-10-06 15:50:13 EDT
But, the pop-up warning only if a dictionary word for the root password. I think the bar showing the effectiveness of passwords is the best solution with the pop-up. Because the pop-up indicates only the dictionary words but not the rest...
Comment 4 Andy Lindeberg 2008-10-06 16:03:44 EDT
That not the case, actually. We pop up a message if your password is a dictionary word, if it is less than 6 letters long, if it's a sequence of characters, if there are not enough different characters, and so on. I don't know all of the messages off the top of my head.
Comment 5 Chris Lumens 2008-10-06 16:10:10 EDT
All the password checking is provided by libuser, so whatever password controls you see in the account adding tool is also done in anaconda.
Comment 6 John Poelstra 2008-10-10 18:59:05 EDT
Has this bug been addressed?  Should it remain open?
Comment 7 Andy Lindeberg 2008-10-10 21:31:56 EDT
For number 1, the best workaround at the moment is to use the text box in the hostname screen to test your keyboard layout if you're concerned about it being accurate. Before editing anything in that area, we need to figure out what we want it to be doing.

As for number 2, I believe that typing the first few letters of a city currently is working, but I would have to double check on that one. Can confirm on Tuesday (if we have a working rawhide).

For number 3, IMO what we do currently to warn people about insecure passwords is sufficient.

And as for 4, we will happily accept patches, but I don't know that we will work on this until we take a hammer to how we handle setting the keyboard in general, which probably won't be until after F10 is released.
Comment 8 Bug Zapper 2008-11-25 21:16:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.