Bug 446750 - acsite.m4:6594: error: this file was generated for autoconf 2.61.
acsite.m4:6594: error: this file was generated for autoconf 2.61.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 16:43 EDT by Robert Scheck
Modified: 2008-07-08 08:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.6.9p17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 08:52:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sudo-1.6.9p13-ac262.patch (683 bytes, patch)
2008-06-07 10:21 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2008-05-15 16:43:28 EDT
Description of problem:
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.55845
+ umask 022
+ cd /usr/src/rpm/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/rpm/BUILD
+ rm -rf sudo-1.6.9p13
+ /bin/gzip -dc /usr/src/rpm/SOURCES/sudo-1.6.9p13.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd sudo-1.6.9p13
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo 'Patch #1 (sudo-1.6.7p5-strip.patch):'
Patch #1 (sudo-1.6.7p5-strip.patch):
+ patch -p1 -b --suffix .strip -s
+ echo 'Patch #2 (sudo-1.6.9p4-login.patch):'
Patch #2 (sudo-1.6.9p4-login.patch):
+ patch -p1 -b --suffix .login -s
+ echo 'Patch #3 (sudo-1.6.9p4-getgrouplist.patch):'
Patch #3 (sudo-1.6.9p4-getgrouplist.patch):
+ patch -p1 -b --suffix .getgrouplist -s
+ echo 'Patch #4 (sudo-1.6.9p12-noPam.patch):'
Patch #4 (sudo-1.6.9p12-noPam.patch):
+ patch -p1 -b --suffix .noPam -s
+ echo 'Patch #5 (sudo-1.6.9p13-audit.patch):'
Patch #5 (sudo-1.6.9p13-audit.patch):
+ patch -p1 -b --suffix .audit -s
+ autoreconf
acsite.m4:6594: error: this file was generated for autoconf 2.61.
You have another version of autoconf.  If you want to use that,
you should regenerate the build system entirely.
acsite.m4:6594: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
acsite.m4:6594: error: this file was generated for autoconf 2.61.
You have another version of autoconf.  If you want to use that,
you should regenerate the build system entirely.
acsite.m4:6594: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
autoreconf: /usr/bin/autoconf failed with exit status: 63
error: Bad exit status from /var/tmp/rpm-tmp.55845 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.55845 (%prep)

Version-Release number of selected component (if applicable):
sudo-1.6.9p13-6
autoconf-2.62-1

How reproducible:
Always, since autoconf-2.62-1 is in Rawhide.

Actual results:
acsite.m4:6594: error: this file was generated for autoconf 2.61.

Expected results:
Working rebuild as before with older autoconf.
Comment 1 Robert Scheck 2008-06-07 10:21:48 EDT
Created attachment 308611 [details]
sudo-1.6.9p13-ac262.patch

The attached hackish patch makes for me sudo rebuilding with autoconf 2.62.
Comment 2 Peter Vrabec 2008-07-08 08:52:43 EDT
fixed in 1.6.9p17-1

Note You need to log in before you can comment on or make changes to this bug.