Bug 446773 - CS.cfg limited to 10m for cert issuance
CS.cfg limited to 10m for cert issuance
Status: CLOSED DUPLICATE of bug 472006
Product: Dogtag Certificate System
Classification: Community
Component: Certificate Manager (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Ade Lee
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-05-15 18:40 EDT by Chandrasekar Kannan
Modified: 2015-01-04 18:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 10:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-05-15 18:40:04 EDT
During a recent high volume test, we noticed that the default
CS.cfg is hardcoded to have a range of 10 million certs for the CA. 

We need to increase this limit.
Comment 1 Bob Lord 2008-05-15 19:05:09 EDT
Also, I seem to recall that in the CS.cfg had "0x10000000" and the UI said
"1,000,000" (decimal).  It can't be both. Need to verify my memory.


Comment 2 Ade Lee 2009-02-06 00:57:28 EST
CS.cfg has a limit of 0x10000000 (hex) in terms of the number of certs issued.
It also however, has a limit of 10000000 (decimal) for requests.  Good thing we're consistent!

If the new serial number management code is enabled, however, the range of certs and requests available will automatically increase as new ranges are added, when the number of available numbers falls below a low water mark.

So, presumably we can close this bug - either as NOTABUG or as a duplicate of the serial number management bug.

https://bugzilla.redhat.com/show_bug.cgi?id=472006

Chandra, how do you want to proceed?
Comment 3 Ade Lee 2009-02-06 14:11:12 EST
Ok - marking as modified so QE can check.

Note: serial number management is not enabled by default.  It can be amanually enabled.  It is enabled by default when cloning occurs.
Comment 4 Chandrasekar Kannan 2009-06-08 10:19:49 EDT
Reading again, I do realize that this is a dup of 472006

*** This bug has been marked as a duplicate of bug 472006 ***

Note You need to log in before you can comment on or make changes to this bug.