Bug 446787 - Unsupported media button
Unsupported media button
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 20:46 EDT by Jacob Masaki
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 06:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Masaki 2008-05-15 20:46:04 EDT
Description of problem:

One of the media buttons on my laptop is unsupported.  It isn't that it's not
mapped to any command, but simply that GNOME doesn't even notice if I press it
(if I attempt to assign hotkeys, it doesn't notice the keypress).  

The button in question is labeled with a house, so I think it generally would be
considered a "home" button.  

The other media keys (mute, volume up, volume down, next track, previous track,
stop, and play/pause) all work.  

Also, this key works under Ubuntu since 7.04, and has not worked under Fedora
since Fedora 8.  (I decided to wait until the Fedora 9 release hoping it would
be fixed by an update to HAL.)  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Press the media button labeled with a house
  
Actual results:
"Keyboard Shortcuts" does not notice a button has been pressed when attempting
to assign the key.  

Expected results:
"Keyboard Shortcuts" notices the keypress, and allows assigning the key to an
action.  

Additional info:
Comment 1 Richard Hughes 2008-05-30 07:41:08 EDT
Is this on a laptop or just a multimedia keyboard?
Comment 2 Jacob Masaki 2008-08-09 01:38:42 EDT
Sorry for taking so long to reply to this, that's totally my bad.  I just got around to re-installing Fedora 9 on my laptop.  

This is one of the built in media keys on my laptop.  

I tested to see if this was fixed with the Fedora 10 alpha live CD (x86_64) and the button still did not work, though none of the other buttons stopped working, so there's been no regressions.
Comment 3 Scott Glaser 2009-04-09 14:03:16 EDT
Jacob,
Are you still running Fedora 9, or have you upgraded to 10 or Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using? Also could you please provide the make and model of the laptop.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Jacob Masaki 2009-04-12 17:45:52 EDT
I've upgraded to Fedora 10, and the media key now works.  Sorry for not replying sooner.  

$ rpm -q hal
hal-0.5.12-14.20081027git.fc10.x86_64

I'm running a Dell 1420n, from shortly after they started shipping them with Ubuntu (mine came with 7.04, I think).  I don't actually know how to be more specific than that.
Comment 5 Scott Glaser 2009-04-13 06:44:24 EDT
Jacob,

Thanks for your rapid response to this request for information. Based on your last comment I am going to close this bug.  Should you experience these symptoms again, feel free to open a new bug against the current component.

CLOSED: ERRATA

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.