Bug 446793 - kdiff3 will not compare two Fedora 9 ISO images
kdiff3 will not compare two Fedora 9 ISO images
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdiff3 (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Neal Becker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 22:16 EDT by Landon Kelsey
Modified: 2008-05-16 08:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 07:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of the kdiff3 crash (96.65 KB, image/jpeg)
2008-05-15 22:16 EDT, Landon Kelsey
no flags Details

  None (edit)
Description Landon Kelsey 2008-05-15 22:16:00 EDT
Description of problem:  kdiff3 will not compare two Fedora 9 ISO images 




Version-Release number of selected component (if applicable):


How reproducible:

download Fedora 9 iso image for installation

copy/backup to a DVD (the files were written like ordinary files for backup)

copy the file (Fedora 9 iso image for installation) from the DVD to a directory
in the /root directory

compare the downloaded file to the file read from the DVD 

see attached snapshot for crash in kdiff3

I suppose the Fedora 9 iso image for installation is some kind of different file.

This was an attempt to verify the backup of the files used to burn the install
DVD (that worked perfectly)

A problem in k3b hinders this verification since an error is reported when the
iso burn is verified. kdiff3 DID work to at least compare the 4 different
installed DVDs



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Landon Kelsey 2008-05-15 22:16:00 EDT
Created attachment 305568 [details]
snapshot of the kdiff3 crash
Comment 2 Landon Kelsey 2008-05-15 22:17:27 EDT
copy/backup to a DVD (the files were written like ordinary files for backup)

corrected to

copy/backup to a DVD (the file was written like an ordinary file for backup)
Comment 3 Landon Kelsey 2008-05-15 23:13:52 EDT
regular old diff did work!

[root@LMKIII ~]# cd test
[1]+  Exit 1                  kdiff3  (wd: ~)
(wd now: ~/test)
[root@LMKIII test]# lsa
total 3500208
drwxr-xr-x  2 root root       4096 2008-05-15 20:36 ./
drwxr-x--- 64 root root       4096 2008-05-15 21:41 ../
-r--r--r--  1 root root 3580680192 2008-05-15 00:43 Fedora-9-i386-DVD.iso
-r--r--r--  1 root root        773 2008-05-15 00:53 SHA1SUM
[root@LMKIII test]# diff Fedora-9-i386-DVD.iso /root/F9Georgia/Fedora-9-i386-DVD.iso
[root@LMKIII test]#                           
Comment 4 Neal Becker 2008-05-16 07:02:26 EDT
Please report this to kdiff3 upstream.

I wouldn't really have expected to use kdiff3 to compare binary files.  It
wouldn't be useful even if it didn't crash.  What would you expect it to do that
you couldn't do with a non-gui tool such as cmp?
Comment 5 Landon Kelsey 2008-05-16 08:27:08 EDT
how would anybody know what anything does with the state of documentation the
way it is!

I would never complain but since you asked!

I thought kdiff3 was a gui version of diff that as I stated worked!

Everybody lives in their own little world where everybody is familiar with a few
things and the rest of the world must presume! Making "good" presumptions is the
way successful Linux users are successful! Take k3b! Reading/writing CDs/DVDs is
a career unto itself! I was lucky (?) to have produced 4 working F9
installations DVDs. No wonder many neophytes give up and return to Bill!
Turns out (see other bugs) there is no way to verify the install DVD is correct!
Why? Burning the ISO image with verify always gets an error!

I did make 4 install DVDs and using kdiff3 compared all 4. Unlikely all 4 are bad!

I am surprised there is any controversy about why anybody would maintain a dual
boot system! I don't like MS!

Note You need to log in before you can comment on or make changes to this bug.